Final Cut Express Quits on Launching

Asked By 0 points N/A Posted on -

I am trying to launch Final Cut Express on my Mac OS X. But the error below is showing. It just keeps on quitting when opening. I tried to uninstall the program and then re-install it back only to get the same error message. How can I resolve this issue?

The application Final Cut Express quit unexpectedly.

Mac OS X and other applications are not affected.

Click Relaunch to launch the application again. Click Report to see more details or send a report to Apple.

Ignore     Report…     Relaunch


Answered By 70 points N/A #120566

Final Cut Express Quits on Launching



In order to fix this issue, you might need to delete Final Cut Express preferences. To do so,

1. Go to “~/Library/Preferences”.

2. Delete the file called “” from the Preferences folder.

3. Also, delete “Final Cut Express User Data” folder from there.

Also, create a new user account and then open the project under the user account. Don’t forget to make the account with administration privilege.

Also, try removing Final Cut Express and then re-install it.

Login/Register to Answer

Related Questions