Fedora 15 Upgrade Problem issue

Asked By 240 points N/A Posted on -



I am using windows XP with Fedora 14 on my computer. When i upgraded from fedora14 to Fedora15 (Lovelock – Released Yesterday) everything installed perfectly.

I have installed Grub on partition 1 of the hard-disk. Its was loading properly and fedora was booting up, but i was not able to get the login screen. I am getting a cursor moving on black screen with white spots on the screen.

I tried Google search and re-upgrading fedora15 which took just 15 minutes 2nd time. But the problem is still the same.

When i pressed F2 while booting fedora, i got to know that its getting stuck at something.

LSB Started: Stopped/resume apache services and when i booted again and checked it got stuck on libvirtmanager.

After this, i get a blank black screen with cursor movement only (No Login Screen).

I have important data on /home partition of fedora and i can't re-install it.

And the big problem is i can't access this partition through windows XP.

Is there any way to get rid of this blank screen and get the login-screen.

I remember i installed following packages in fedora14 b4 upgrading to fedora15.

Plymouth skins.

Ati Radeon display card drivers.

Used KDM instead of GDM to customize login screen.

Tell me how can i remove the second package (ATI Radeon Display Drivers For Linux-x86), may b this is creating a problem, but i don`t know how to remove this without logging into the system.

If not, suggest me any way to just recover all my data, so that i can install fedora15 from starting (without upgrading anything)?

Following are the configurations Of my Hard Disk:

Partition 1 (NTFS) = Windows XP (Active partition with grub installed).

Partition 2 (EXT4) = /home.

Partition 3(Ext4) = /.

And two extended partition.

Partition 4 (SWAP) = Swap.

Partition 5 (NTFS) = Movies.

Display Card = ATI RADEON HD 4350.

Thank you.

Best Answer by sazzad128
Best Answer
Best Answer
Answered By 0 points N/A #104158

Fedora 15 Upgrade Problem issue



I am suggesting you a solution.

Last month I face this type of problem. I use Win 7& Ubuntu 11.04. NTFS file system.

I was unable to use my PC. It said Boot manager was missing. I had win 7 in drv: C:/ and Ubuntu on other.

I then reinstalled the win 7 & then copied the Ubuntu folder to another drive with name Ubuntu. Old and after I installed Ubuntu again. I rebooted (it tell to reboot and actually restarts to attempt that with option which you will select to start) and didn't went to Ubuntu rather opened or started Win 7 and copied and replaced (please use TeraCopy and from more > menu select it as / register it as default handler) all the files and folders except the .ico and uninstaller.exe and after I restarted the PC and selected Ubuntu and I saw exactly what i saw it before I got all my folders and files.

Mention here you wont get all your previously installed softwares and updates. About 40%-60% softwares will be missing but no file will be missing. All files will be available as you used it before.

After getting all files and storing them please do two things (I recommend no. 2).

1. Uninstall and reinstall the Fedora.

2. Compress your Windows drive backing up all your files. Then reinstall windows and fedora. [I recommend it as this will delete all boot files, managers and you will get a new Win, PC, Fedora].

One thing after getting all your files from Fedora please use APTonCD software from Linux/Fedora software Centre/list and make a meta package and save the .ISO in your desktop and copy it to pendrive. (use it for next use to see formerly which things were installed).

I believe it will work as all Linux&UNIX cores are same. They are unique.

Also make all drives as NTFS systems and use fedora beside XP.

Install it while you are logged in XP and then insert the CD/USB drive.

This will do best.


Answered By 0 points N/A #104159

Fedora 15 Upgrade Problem issue


It is most likely that the ATI Radeon drivers that you installed are responsible for the behavior your Linux fedora is having right now, or it might be the upgrade in general. I will suggest the following workaround for you:
First thing that you should try doing is removing the ATI Radeon drivers that may be affecting your system's performance and see if it works fine.
In case the system still continues having problems, then you will need to remove the fedora upgrade you installed and go back to the old version. It may be because of compatibility issues that the problem is happening, and therefore the upgrade you made cannot be able to work well on your system.

-Clair Charles

Login/Register to Answer

Related Questions