Facing Error Certificate Is Not From A Trusted Certifying Authority Using Remote Desktop

Asked By 0 points N/A Posted on -
qa-featured

I am facing certificate security error. When I use a remote desktop, it gives me a pop-up error saying certificate is not from a trusted certifying authority that is the authentication to the remote computer is not complete.

SHARE
Answered By 10 points N/A #293241

Facing Error Certificate Is Not From A Trusted Certifying Authority Using Remote Desktop

qa-featured

This error could be due to following reasons:

  • The website is using a certificate that is free and is not as safe as a commercial certificate; it is a self-signed certificate.
  • The website uses a free SSL certificate.
  • Some certificate chain is missing between the client and website.

This solution of the problem is:

  1. Trusting the issuer – For this, you need to view and install the certificate. After this in the certificate store, select the ‘Trusted Root Certification Authorities’ and click ‘OK.’
  2. Move the certificate to the Trusted Root Certification Authorities, if you have already installed certificate at some other location. For this type ‘certmgr.msc’ in the run command and click ‘OK.’ Search the certificated and copy it to the ‘Certificates folder’ in Trusted Root Certification Authorities.
Answered By 590495 points N/A #315530

Facing Error Certificate Is Not From A Trusted Certifying Authority Using Remote Desktop

qa-featured

This error is the same with “The authentication certificate received from the remote computer has expired or is not valid”. You may receive this error when you start Remote Desktop Connection and the cause is the date and time settings on your computer. You may encounter this when the two computers don’t have the same date.

To fix the problem, set the correct date or just synchronize it with an internet time server. To do this, right-click date and time on the system tray and select “Adjust date/time”. In “Date and Time” dialog, under “Date and Time” tab, click “Change time zone” then select your correct time zone on the next screen and then click “OK”.

Next, go to “Internet Time” tab then click “Change settings”. In “Internet Time Settings” dialog, make sure “Synchronize with an Internet time server” is checked. In “Server”, select a time server from the dropdown list then click “Update now”. In Windows 7, you can select between:

  • time.windows.com
  • time.nist.gov
  • time-nw.nist.gov
  • time-a.nist.gov
  • time-b.nist.gov

In Windows XP, there are only two options available:

  • time.nist.gov
  • time.windows.com

Click “OK” all throughout then try Remote Desktop Connection again and see if it works. If this doesn’t work, repeat the same steps on the other computer. It should fix the problem.

Login/Register to Answer

Related Questions