Errors with Hokuyo URG-04LX Laser RangeFinder

Asked By 210 points N/A Posted on -

Hi guys! I have a problem with Hokuyo URG-04LX Laser RangeFinder or LIDAR. As I understand, this should work with LabVIEW. I installed the driver correctly according to the tutorial. But when running s program, I encountered errors. I don’t know if there is something wrong with the configurations. How can I configure LabVIEW with Hokuyo? I am running a sample program that is included in Hokuyo driver which can be found in NI Example Finder with LabVIEW Robotics. If I run the program, I got errors which I posted below. By the way, I’m using LabVIEW Robotics 2009 Service Pack 1. Please help me with this.

Error -1074000350 occurred at Hokuyo URG Series.lvlib:Error

Possible reason(s):


Error -1074003951 occurred at Hokuyo URG

Possible reason(s):

The ID Query failed. This may mean that you selected the wrong instrument or your instrument did not respond. You may also be using a model that is not officially supported by this driver. If you are sure that you have selected the correct instrument and it is responding, try disabling the ID Query.

Answered By 0 points N/A #114062

Errors with Hokuyo URG-04LX Laser RangeFinder


The labview software that you are using has some compatibility issues with the hokuyo and it has been there for a very long time but neither of the two has ever tried to solve it.

While i was searching over the internet most of the people left using one of the two. But in my case I would like to point out few things to try to figure it out.

First make sure that you have updated all the libraries of the labview software and have the updated version of the software.

Reinstall the hokuyo and redefine all the parameters.

Look for any other readymade examples over the internet to make things easier for you. if they work then there is something wrong with your first example

Login/Register to Answer

Related Questions