Error when opening Microsoft Management Console (MMC)

Asked By 0 points N/A Posted on -


I was installing several snap-ins in MMC on Win 2008 Server including MS Exchange, AD and Group Policies and it completed fine.  Then, I tried opening MMC when this error message appeared on the screen, see screenshot below. 

I have searched the web and have seen several solutions.

I tried the site where there was a FIX IT button, but this didn’t work. 

Any advice on how to fix the problem? 

Thanks in advance.

Microsoft Management Console

MMC cannot initialize the snap-in

                Name: <unknown>

                CLSID: {E355E538-1C2E-11D0-00C04FD8F93}

Answered By 5 points N/A #97074

Error when opening Microsoft Management Console (MMC)



I have some solutions to solve your issue about Microsoft Management Console. 

  1. First, you need to close the and remove the site from MMC.
  2. Second, just delete the file "adminconsole cache from Documents and Settings%Surname%Application DataMicrosoft MMC.
  3. And lastly, you will start Microsoft Management Console and reconnect it to site server database.

You can also try this:

  1. Open windows and system32 and look for mmc.config.
  2. And then rename mmc.config into mmc.config.bak and that's it.
  3. More simple and easier but still depends on which of these solutions will help you solve your issue regarding MMC. I hope it helps.


Login/Register to Answer

Related Questions