Error in Updating Google Chrome

Asked By 10 points N/A Posted on -
qa-featured

I have this error from updating Google Chrome. It says:

"Failed to fetch http://dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_17.0.963.54-r121622_amd64.deb"

404 Not Found [IP: "MyIP"]

I don't know but maybe Google created a new package this February 2012 but still hadn't uploaded it.

Does anyone have the same error?

How to fix it?


 

SHARE
Best Answer by Szakacs Regis
Best Answer
Best Answer
Answered By 5 points N/A #94636

Error in Updating Google Chrome

qa-featured

Hi there, I have read your post and I had a similar problem as you have, but I went to this site and followed all the instructions given. I was able to fix the issue on updating my Chrome browser.

Answered By 0 points N/A #94637

Error in Updating Google Chrome

qa-featured

I understand your problem. I download Google Chrome just a week ago.

At first I start to download it in my native language that means Bengali, but then it was not downloaded perfectly then again I start to download it in the international language that means English then it was downloaded perfectly and now I am using it properly without any hesitation. Now in case of you I think your downloaded version is up-to-date that's why you are facing such a problem.

I request you to check your version, the latest version is 19.0.1041.0 Beta.

If your version is not that, so go to the following site and download it.

Thank you.

Login/Register to Answer

Related Questions