Error found in the Ubuntu software center

Asked By 50 points N/A Posted on -


I am using Ubuntu 10.10. I was trying to re-setup indicator weather and then I found this error in the Ubuntu software center. After that, I click repair, still the same message shows.

I shut the Ubuntu software center and then tried again, but found the same message.

Items cannot be installed or removed until the package catalog is repaired. Do you want to repair it now?

Once Update Manager has finished the repairs. you can close it and return to the store.

Cancel Repair

EDIT 1: On using sudo apt-get install aptitude, it said that I already had aptitude setup. Then I started sudo apt-get reinstall indicator-weather and the output was:

"Indicator-weather is not currently installed, so it will not be reinstalled. The following packages will be REMOVED: libgio-cil{u} 0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded. Need to get 0B of archives. After unpacking 274kB will be freed. Do you want to continue?

I clicked yes, but the trouble still persists.

EDIT 2: I tried using sudo apt-get install indicator-weather, but found the following error.

Reading package lists… Done. Building dependency tree Reading state information… Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: indicator-weather : Depends: gir1.2-glib-2.0, but it is not installable

E: Broken packages.."

What should I do now? Please help.

Thanks a lot.

Answered By 0 points N/A #154845

Error found in the Ubuntu software center


Good Day, upon reading your problem and based on my research you are experiencing a bug please try this suggestion that maybe can help your problems.

Try Downloading the package libqtcore4_4%3a4.8.1-Oubuntu4_1_1386.deb.

Just click the link

And download it into your home directory using a web browser and open a terminal page and type This > sudo dpkg –I *.deb well if that command didn’t work then try this one – This > sudo apt-get –f install.

As they say the problem occurs because you are downloading an older version of the package.

Login/Register to Answer

Related Questions