Error connecting iPhone OS- Help me!

Asked By 0 points N/A Posted on -

Hi Techyv,

I use Iphone software 3.1.3.My iphone is listed in the Xcode Organizer Window. I received the required keys or certificate (whatever you call). However, when I connect my iPhone to my laptop and choose ‘Build and Go’, received the above error. I tried rebooting the device and the Xcode. 
Please help. It was not a cakewalk as I thought.

Error: “Error Starting Executable

No provisioned iPhone OS device is connected.”



Answered By 0 points N/A #90491

Error connecting iPhone OS- Help me!



If you have upgraded your device to the latest OS, this usually means XCode needs an upgrade too.  The version of XCode installed on your computer may be out of date and it does not recognize your new OS.

All you need to do is check if the operating system version is supported by XCode.

According to my research here is what you need to do turn off your device, wait for at least 1 minute to give the device a time to really shut down and cool down.  Restart your Xcode after clearing all caches and all targets.  Restart your device.  Reconnect and try again.

Also your SDK version may be old. You need to update it and retry. Restart the device to load certification.


These are possible solutions or suggestion that might help you and this has worked for a lot of users experiencing the same problem as  yours.  I hope this helps.

Login/Register to Answer

Related Questions