Error accessing application id tfs from secure store service

Asked By 200 points N/A Posted on -

Hi all,

I have been doing this just recently and having a hard time checking on what might be wrong. I am really going crazy about this kind of problem that others might have been experiencing too. I am using a dual sever setup, the TFS 2010 and SharePoint 2010. I got this kind of error saying


An error occurred while accessing

application id tfs from Secure Store Services.

The following connections failed to



Learn more about data refresh”

Every time I go for one of the reports to the dashboard page in SharePoint. I tried reloading and refreshing the page, but the same error appears on my screen. Then if I click a report on the excel reports on the SharePoint portal, I also get the same error. I tried clicking ok to the error message and a report showed up, but do not contain any data. So can anyone find a solution to this kind of problem?


Best Answer by Felipa Dolore
Answered By 0 points N/A #125559

Error accessing application id tfs from secure store service


Hello Monica,

This problem is common when using both TFS and Microsoft Office Sharepoint Server or MOSS. Microsoft Excel utilizes a default feature called Secure Store Services or SSS for abbreviation.

This feature is for people who do not have direct access to the data to be able to see the data in Excel Web Services or EWS. Now, SSS is usually configured with Sharepoint automatically.

It is commonly just the TFS that needs to be configured with Secure Store Services. However, based on your report, you have to reconfigure your Secure Store Services setting with Microsoft Office Sharepoint Server as well. You can configure your SSS and EWS by following this link.

Answered By 0 points N/A #195583

Error accessing application id tfs from secure store service



I suppose following the given steps will lead to a solution regarding this error.

The data connection usually uses Windows authentication and what happens is that user credentials might not be delegated. Follow the steps to fix this problem.

1. On ‘Team Foundation Server Administration Console’ Click on the TFS server.

2. Click on ‘Extensions for Sharepoint Products’ and select the Sharepoint Web application used by you.

3. Now, Click on Modify access.

4. Enter the user with access rights to the reports inside the Enterprise Application Definition area and then click on OK.

I hope this information is helpful.

Best Answer
Best Answer
Answered By 20 points N/A #195581

Error accessing application id tfs from secure store service

You need check that the account has actual access to the data. These steps are to verify the proxy account for Secure Store Services:
1. Log in to SharePoint 2010 server as administrator.
2. Click SharePoint Central Administration > Application Management > Manage Service Applications.
3. Click Secure Store Service (not the proxy).
4. Click on the Secure Store Services ID to check.
5. Click Next.
6. The next window will display the UN and Password that are being used.
7. To make changes, go back to Secure Store Service (which is not the proxy) and click "Set Credentials".
8. Connect to the data warehouse with the existing credentials to test the SSAS access. Use SQL Management Studio and select Analysis Services instead of the database engine.

Login/Register to Answer

Related Questions