Error 1920. Service McAfee Framework failed to start

Asked By 20 points N/A Posted on -


This morning McAfee came up with this error and tells me that it doesn’t have sufficient privileges to start. If I click Ignore nothing is happening but is not running and if I click Retry the same error appears again. Does anyone have any idea how can this be solved? Is there a problem with antivirus or with my Windows XP? Thank you.

McAfee VirusScanEnterprise Installer Information

Error 1920. Service McAfeeFramework (McAfeeFramework) failed to start. Verify that you have sufficient privileges to start system services.

Abort Retry Ignore

Answered By 110 points N/A #173656

Error 1920. Service McAfee Framework failed to start


You are encountering this error because of an error in the registry which mentions Windows to the incorrect location for the McAfee background service. To resolve this issue you need to modify the Windows registry to display the correct location of the McAfee background service. Also have some technique to solve this problem.

Solution 1:

You can solve this with the McAfee VirusScan Enterprise 8.7i Patch 1. It is available in the McAfee downloads site, using a valid Grand Number. For accessing you need a valid Grant Number. Go this site which is provided additional information about the McAfee download sites.

Solution 2:

You can apply Patch 2 for VSE8.7i if you have Symantec Software Virtualization and Streaming installed to fix this issue. If the problem persist, apply the following general workaround.

1. Start the “VSE 8.7i” installation location.

2. Wait for the 1920 error to appear.

Note: Don’t terminate the 1920 error dialog box.

3.Now go to “Start” menu>>”Run”>> and type “regedit”>>and click “OK”.

4. Navigate to & expand the following key :  


5. Select the sup-key “mfeapfk”.

6. Now double click “ImagePath” on the right side of the Window and select “Modify”.

7. Change the information in the “Value Data” box from "system32driversmfeapfk.sys" to "C:windowssystem32driversmfeapfk.sys" .

8. Click “OK”.

9. Close the registry editor and restart the computer.

MaAfee VirusScan Enterprise should now work normally.

Login/Register to Answer

Related Questions