Disable data writing on my pen drive

Asked By 7060 points N/A Posted on -

My pen drive has a problem which is, it disables data writing on my pen drive. These are the types of problems that I can’t understand. What is the problem of My Computer or my USB pen drive.

Now I need a solution for this problem.

Best Answer by Samanthajp
Answered By 0 points N/A #79769

Disable data writing on my pen drive


There is no official process of making the write protection disabled. Here we have a good trick to do this

  • Go to Start -> Run -> Type Regedit and press Enter.

Navigate to the below location

  • HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlStorageDevicePolicies

And click on WriteProtect and change the value data to 1 to disable and set 0 to enable write in USB drives.
But there are some tweaks present in the internet. The modified registry are there and they are intended to be used at their own risk.

  • Download this tweak to disable writing to USB drives. Also make sure that users are not administrators on this system otherwise they can change the settings back.
  • www.howtogeek.com/wp-content/uploads/DisableUSBWrite.zip



Best Answer
Best Answer
Answered By 0 points N/A #79770

Disable data writing on my pen drive


This problem might be a virus that is transmitted from the pen drives which transfers virus to the system. It can cause different types of virus like Trojan through portable devices.

To protect your computer from the virus you need to follow a few simple steps

  1. First protect your pen drive from the viruses,, you need to create a blank file named autorun.inf using the notepad and place it in the root directory.
  2. So when you insert your pen drive on any virus infected computer, it will show a message saying replacing the file etc which is located in the root directory of your USB device and that is nothing but a virus. So don’t allow the virus to replace the file on your drive.
  3. Open your pen drive and double click the thumbscrew.exe to start it , it will be loaded into your system tray.

Select the option as shown in the images below

You could Disable USB Writing ( as shown in the image below)

if you want to Enable USB Writing ( as shown in the image below )

Hope you got the solution.


Login/Register to Answer

Related Questions