Difficulty in compiling Thor 1.1 on 10.7.4

Asked By 10 points N/A Posted on -

Hi guys,

I am having a very difficult time in compiling Thor 1.1 on 10.7.4. 

If I am posting in the wrong place and breaking any rules, I apologize! I have scanned through this thread and tried all suggestions, but keep getting the same error:


CMake Error at CMaketista.txt:92 (message):

SFML directory not found. Set SFMLDIR to SFML a top level path (containing

"Include" and "lib" directories).

Configuring incomplete, errors occurred;

SFML and CMake are new to me. Therefore, I don't really know where I am going wrong. If I sound silly or stupid, tell me! There is only one folder I can 'lib' and 'include' in, and that is /Developer/usr/lib/clang/3.0.

If I try to compile using Thor 2.0, I get a different error:

SFML found, but version too low (requested: 2, found: 1.x)
> SFML directory not found. Set SFML_ROOT to SFML's top-level path (containing "include" and "lib" directories).
> Make sure the SFML libraries with the same configuration (Release/Debug, Static/Dynamic) exist.

This is all very strange to me and any help would be fantastic.


Answered By 10 points N/A #152805

Difficulty in compiling Thor 1.1 on 10.7.4


Hello Emily,

From the image you have posted above I highly suspect that you are getting the error most probably because of the following reasons:

  • The path you are providing for the source may be wrong. You will therefore need to try and change that, make sure that the path you are providing is correct and then see if it works.
  • Check the location for the binaries and the path pointing to it and ensure that you have spelled them correctly.

The problem may also be with the Thor application itself and therefore it may need a reinstallation to solve the issue.

Hope this helps.



Login/Register to Answer

Related Questions