Delphi 2010 program has started being unsuccessful

Asked By 10 points N/A Posted on -


Hello experts,

I am using Delphi 2010 program for long time, but suddenly, it has started to be unsuccessful with system error message $C0000008 (invalid file handle).

So, I tried an experiment code snippet, which is just a button handler:

TFileStream.Create (c:temptestfile.tmp)

That also collapses with system error $C0000008.


I want to mention that I have complete access rights to that folder as well as the file and the code runs well, when I tried it outside the IDE or with essential debugging off.

As far as I'm conscious, I haven't created any transforms to Delphi or the OS (Vista 32-bit).

I'd like better not to have the bother of uninstalling as well as re-installing Delphi, if there's something else to look into first.

Please help.


Best Answer by Sharath Reddy
Answered By 0 points N/A #150006

Delphi 2010 program has started being unsuccessful


Dear Robert,

The problem have started because your Windows update itself automatically or most probably, your antivirus software updates  with a corrupt or damaged version. Try to refresh your antivirus software by simply uninstalling it and then re-install it back. 


Best Answer
Best Answer
Answered By 590495 points N/A #150007

Delphi 2010 program has started being unsuccessful



If you are already using the software for quite some time now then it’s possible that some of its installation files or components got corrupted. Since this problem suddenly happens and you don’t expect it to occur, why not try doing another clean installation on the software to remove any corrupted files that may have developed along the way.

Uninstall your software then restart your machine when asked. After booting, check your computer for any possible errors. Use a disk utility application to check the system. For a much thorough diagnostic test on your machine, use disk utility applications like PC Tools Performance Toolkit, or Norton Utilities. Install Delphi again then see if this fixes the problem. You may also visit Delphi’s official website and download the latest version so you can upgrade the present version installed on your computer.

Answered By 0 points N/A #150008

Delphi 2010 program has started being unsuccessful



HI there,

If your hard disk gets old and has bad sector then it is impossible to run any program correctly. You can search for hard disk bad sector and use third party software to fix this.

Turned Integrated Debugging OFF and that seems to have solved the problem, I think.

You can also make some change in your debugger options:

[TAB OS-exceptions] Handled by: User program and run unhandled
[TAB Language exceptions] Exception types to ignore (just add the exception)
And make sure you have integrated debugging True…


Login/Register to Answer

Related Questions