CoffeScript error occurred when tried to check syntax

Asked By 60 points N/A Posted on -


Anytime I try to attempt to do something like check syntax (Alt+Shift+S) but nothing happens and receive the following error message saying “Env: node: no such file or directory”.

I can’t get any command for this plugin to work.

Can I get solution to resolve this matter?




Node: No such file or…

Env: node: no such file or directory.


Answered By 5 points N/A #176850

CoffeScript error occurred when tried to check syntax


Your coffeescript might be coupled with another plugin in the same directory.

Go to Coffeescript – sublime build then edit the path to:

"path": "/usr/local/share/npm/bin:/usr/local/bin:$PATH"

The line above will fix the build command but not the compile command yet which of course, includes checking for syntax errors.

By default, Homebrew installs the executable node to:


Which is separated by binDir

So, on the compile command, call 

run("coffee", ["-c", "/whatever/"])

In run command, create an env variable.

proc = Popen(command, cwd=cwd, stdout=PIPE, stderr=PIPE)

Login/Register to Answer

Related Questions