Can’t find and add a printer from a local network area?

Asked By 0 points N/A Posted on -

I can’t search and add my printer from a local network, so I was using USB storage device save it from that PC and print to the server, hassle.

It was for sure shared by the server because it was the default printer by other unit.

I tried direct printing and choose add printer and it shows like this:

“The active Directory Domain Services is currently unavailable”

I also tried to us control panel and add printer, and it shows like this:

It can’t search the printer. How can I add a local printer since it was shared.

My printer is Cannon MP250 and Windows 7.

Answered By 0 points N/A #123964

Can’t find and add a printer from a local network area?


Hi there!

To answer your question do you have a domain environment ? or just workgroup ? if you are working in domain environment you need to have privileges to add a printer from network, which means that after printer is shared it must be visible in the network folder. ( if you are having appropriate user rights or privileges ) if you are not in a domain you need to log to the computer which printer attached. just type the IP address of the computer and give credentials to log in ( user name and password ) after successfully login it will show up the shared things in that computer. if printer is shared you will see the printer. simply just double click on the printer and it will ask your permission to install printer drivers. just install it. now you are done. now you can print the document by using your printer.

Secondly check your IP address carefully because you may have different IP address and it will avoid you to contact from existing network.

If you are in a domain environment, please ask your network administrator whether you have appropriate permission to contact a printer and do print jobs


Login/Register to Answer

Related Questions