Cant copy files to External HDD

Asked By 130 points N/A Posted on -


I amusing Windows Vista Home Basic and my problem is that windows gives me an error every time.

I try to copy files from my computer to my external western digital 1TB drive.

It says,

(Error 0x8007045D: the request could not be performed because of an I/O device error).

I tried the windows scan disk on my external hard drive, I tried to perform windows defrag but it takes too long and cancelled it, so to defragment it I downloaded O&O Defrag and fast defragmented it.

Please Help me out as I don’t want to lose my data because of a system crash.

Best Answer by Gary Monet
Best Answer
Best Answer
Answered By 0 points N/A #110261

Cant copy files to External HDD


Hello Erickson!

It’s good that you have already performed a scan on your external drive. That would always be the first step when there is a problem with a hard drive whether it is internal or external. However, it is also important to do a complete defrag of the drive. Does this drive already contain files? Or is this a fresh external drive that you are using to back up your files on?

Here are some solutions that you can try to solve your current problem:
You will have to do a full defrag on your drive, I know this will take some time but it is a lot better than losing your files. I suggest you do this before sleeping so you won’t be bothered much by the time you will be using to defrag your external drive. Once it has completed, go ahead and try it again if it works.
Safely remove your external hard drive and insert the USB cord into another port. If the computer prompts you to install again automatically do so and try backing up your files again.
Check if your hard drive's firmware is properly updated. Go to Western Digital’s website and search for firmware updates.
If this is a fresh external drive, meaning there are no files in it, reformat it and try to copy your files again. Try just to put one file, if even this doesn’t work proceed to the next solution.
Run a Registry Cleaner program to scan for issues. After scanning let the Registry Cleaner “Fix” the selected problems. It will log the fixes it made. See if this solves the error. Registry problems can cause problems during backups.
This could also be a permissions issue. Right click on the files or folders, Select “Properties”, then “Security”, then “Advanced”, Select your User Name, choose “Edit”, Select your “User Name”, Click Edit and put a check on “Full Control”. Click OK until you are exited from all the windows. Try copying the files and see if this has solved your problem.
Are you currently using a backup software or simply copy-pasting the files into your external hard drive? If you are using Vista’s built-in backup software, go to your “System Settings” and remove the checks on the drive you are backing up. This will stop your OS from creating shadow copies. Save the settings then recheck the boxes you unchecked earlier. Try backing up your files again.

For each solution, restart your computer to save changes. Upon boot up, that’s when you should try to back up or copy your files into your external drive.

I hope this helps, this is a rather common problem with different solutions and is not limited to Western Digital external drives.

Good luck and I hope that these solutions are helpful for you and other people that experience this error.

I’ll keep an eye on this thread since it is a common problem without a common solution.

Answered By 0 points N/A #110262

Cant copy files to External HDD


Hello bro,

I read your question with full concentration and determine that you have to connect your external hard drive through cable with USB and check that your Window is getting all the drivers correctly. If Window installs all your drivers correctly then you have to scan your external hard disk if it already contains files.

If it does not contain any files then you have to format your hard disk using any format utilities or use by default Windows format utilities. If the external hard disk contains files then use fragmentation tools either your window default tool or any tool that is available for free distribution.

Applying these steps may solve your problem.

Thanks for asking in

Login/Register to Answer

Related Questions