Xcode 4.0.2 requires Mac OS X 10.6 Snow Leopard

Asked By 30 points N/A Posted on -
qa-featured

Recently I have upgraded my MAC to OS Lion and when I want to run Xcode this kind of error message box appears on my desktop. Also I have updated some tools to Lion Version and still get this error. I don’t know what to do next and I need some help to figure this out. Please someone help me with this error and tell me how can I solve this ?

Thank you !

Xcode 4.0.2 requires Mac OS X 10.6 Snow Leopard.

Install the Xcode Tools version that supports Mac OS X 10.7 Lion.

OK

SHARE
Answered By 70 points N/A #185986

Xcode 4.0.2 requires Mac OS X 10.6 Snow Leopard

qa-featured

Hello,

Xcode is a good choice for developing programs on Mac. But if anyone fails to initialize it properly, he’ll surely won’t get the profit of programming. Your problem looks very disappointing.

It looks like you’re trying to run Xcode 4 which is a very old version. Older versions does hardly run on latest OS so what you need is just to visit this page and get the latest Xcode 5.

If that doesn’t work, you might need to use any other softwares like Xcode. You can use AppCode instead. It has got full compatibility of Xcode so nothing to worry.

This will surely solve your issue.

Login/Register to Answer

Related Questions