WMI Error Access is denied (0x80070005)

Asked By 10 points N/A Posted on -
qa-featured

Hello there, techyv!

Hi there, I hope you can help me with this error. I'm told this error is common when setting up new service accounts for SQL Server Agent.  I haven't encountered this one before. Can anybody please help with this.

WMI Provider Error – Access is denied. (0x80070005).

Thank you!

WMI Provider Error

            Access is denied. (0x80070005)

SHARE
Answered By 0 points N/A #90685

WMI Error Access is denied (0x80070005)

qa-featured

There are several things that can be causing this but most likely it is due to some administration conflicts. First, make sure that you are logged in with an account that is a local administrator (or is a member of local administrators) and has the appropriate permission in the Active Directory.

A workaround to this problem without actually solving it is to open the SQL Configuration Manager and go to properties for the Service. Don't right away trying to change the password, instead go to Browse, type the account name in and choose check names. Then you can go back to the properties and change the password.

To actually locate and fix the problem you need to make sure that the DCom security settings are correct. First, you need to run domcnfg in the command window to being up the Component Services options. Navigate to My Computer, right click, and select properties. Under the COM security tab you need to click Edit Default for Self (Local, Remote), System (Local), and Administrators (Local, Remote). After settings those, you need to click Launch and Activation Permissions, Edit Default and set System (Local launch, local activation), Administrators (Local launch, Remote launch, local activation, remote activation), Interactive (local launch, local activation).

If this does not fix the error, you may want to download the WMI diagnosis tool from Microsoft.

As you very last resort, you can try to remove and re-add the computer in use to the domain, but only do this as a last resort.

I hope this helps!

 

Jen

 

 

 

 

 

Login/Register to Answer

Related Questions