Windows XP Dual Boot Problem

Asked By 430 points N/A Posted on -
qa-featured

I installed two different versions of Windows XP on my hard drive, Windows XP Home Edition and Windows XP Professional, but due to lack of enough space, and my computer is showing slow performance since I only have 1 GB of RAM and 250 GB on my hard disk plus a hundred of applications installed on it, I decided to delete one OS from the same HD.

I formatted the drive where my partition of Home edition is installed. It deletes all the content of the drive D. Normally when you have a dual boot OS, After the POST, it will ask you to choose from which OS you will use, But after formatting Home Edition, I can still see the two OS choices after a startup.

I want to delete the other one so I will not go into the process of choosing, I want to go directly to my Windows Professional after the startup. What do I need to do this?

I then deleted the partition of Drive D and keep the Drive C where my Windows XP Professional is installed, I restarted the computer and still go into the process of choosing from two OS. How can I totally delete the other partition? Please help me with this. The image I attached is the same as the one I am encountering except that the 2nd choice is Windows XP Home Edition.

SHARE
Best Answer by porag
Best Answer
Best Answer
Answered By 0 points N/A #106801

Windows XP Dual Boot Problem

qa-featured

Hello Erin111,

As per your post, I understand that you want to go Windows Professional directly.

1st solution:

There is a file called boot.ini which brings the boot choice to the user. You get the file on your C: drive. If you can't see the file please go to Folder option > Click to view > choose show on the hidden files and folder. A sample boot.ini file is given below:

Warning: Boot.ini is used on Windows XP and earlier operating systems.

[Boot loader]
timeout=30

default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS.0
[Operating systems]
multi(0)disk(0)rdisk(0)partition(1)WINDOWS.0="Microsoft Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows Home" /NOEXECUTE=OPTIN /FASTDETECT

You can delete

multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows Home" /NOEXECUTE=OPTIN /FASTDETECT

Part of boot.ini file to remove windows home from the OS boot menu.

You should change the time out setting from 30 to 0. It will bring your windows professional directly.

[Boot loader]
timeout=30*

2nd solution:

Right click on my computer on desktop > select properties > select advanced from menu button > click on startup and recovery setting > default operating system choose windows professional > set time =0 beside time to display list of operating system > finished with clicking Ok.

Alternate: my computer on the desktop > select properties > select advanced from menu button > click on startup and recovery setting >To edit a startup option manually click on edit button and delete multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows Home" /NOEXECUTE=OPTIN /FASTDETECT

From boot.ini file. And set time 0 on timeout=" " section.

Save the notepad file boot.ini.

3rd solution:

Insert windows installation CD when ask for a repair or install .Choose R for repair (You may need an administrative password for doing this). It brings you on command prompt > write fixboot on command prompt (C/: fixboot) and enter. This command automatically tries to fix your boot.ini file. Restart your computer.

I hope all the solution I mentioned help you to solve the dual boot problem.

Best wishes,

Porag

Answered By 0 points N/A #106802

Windows XP Dual Boot Problem

qa-featured

Go to start—-> Run and type msconfig in the typing area and press enter. Then you will get a dialog box. Select the BOOT.INI tab and select the unwanted operating system and press delete. Be careful when you try to deal with BOOT.INI it is recommended to make a restore point.

System Configuration Utility
Answered By 430 points N/A #106803

Windows XP Dual Boot Problem

qa-featured

I followed both solutions and this result to end the problem I am encountering. Thanks for unending support to all who needed help on their PC. I really like it here in techyv.

Thanks a lot!

Answered By 0 points N/A #195355

Windows XP Dual Boot Problem

qa-featured

Hello Dear,

Thanks for sharing your problem with us.

Dear it is so easy to remove the unwanted operating system from boot selection options.

You do as I say.

First right click on my computer and choose properties. Then choose "Advanced" tab as shown in the picture.

Remove the unwanted operating system

And then click on settings button which is highlighted in the picture.

It will open this window.

Startup And Recovery

In this window choose edit button then this window will appear.

Operating system from Boot selection options

In this notepad file, you have to select that operating system which you do not want to see in boot selection options. Then save it.

And enjoy.

Thanks.

Login/Register to Answer

Related Questions