No of visitors who read this post: 3958
Category: Google Chrome
Type: Question
No votes yet

I have installed IDM download manager. It is working on Mozilla Firefox, but not on Google Chrome. When I right clicked on any file, there is no option like "Download by IDM". I want to activate IDM for my Google Chrome. What should I do to activate my IDM for Google Chrome.

idm-isnt-working-google-crome-browser

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 29754

IDM only allows browser integration for the right click option in Internet Explorer and Mozilla-based browsers only. Fortunately, it also has an option for advanced browser integration in other browsers which allows IDM to monitor selected file types. To enable this option, follow the steps below:
 
  • Click on the options button on IDM, and on the general tab, check the "Use advanced browser integration" check box and ensure that Google Chrome is checked on the list as shown below:

Internet Download Manager Configuration

 
  • Next, go to the File types tab and check if the file types you wish to download are in the list. From your image, I see you wish to download a .WMV file. You can just type in WMV in the list as shown below. When this is done, IDM will start downloading such files automatically when you click on the link.

Use advanced browser integration

  • Alternatively, you can right click on the link in Chrome browser. Select the copy link address option in Chrome, open IDM, click on the Add URL button which will open a dialog box with the URL already pasted, as shown below. Click ok and the download automatically begins. I hope one of these solutions works for you. 

URL found in clipboard

# Comment Id: 34501

Hi,
 
The IDM isn’t working on Google Chrome in browser. You can fix the issue by opening  the Internet Download Manger and going to the option; click the download; then after that go to the general tab. You must uncheck Google Chrome in the option.
 
After finishing unchecking the Google Chrome, you must try to run the system if it is working properly. You can use the Get Google Chrome to integrate the IDM in Google Chrome.

# Comment Id: 36471

Hi,

The IDM isn’t working on Google Chrome, in browser.  You can fix the issue to open the Internet Download Manger and go to the option, click the download.  Go to the general tab, you must uncheck the Google Chrome in the option.

After finishing unchecking Google Chrome, you must try to run the system if it is working properly. You can use the oGet Google Chrome to integrate the IDM in the Google Chrome and then if it still working at all maybe you must update first you IDM version or try this just simply inactivate the Advanced browser integration in the option simply go to the IDM menu just select the option and simply click the General.