Why my apache of xampp is not working?

Asked By 0 points N/A Posted on -
qa-featured

I use xampp to activate localhost for working with joomla. But now I can not activate Apache on xampp. When I click on start, there is a word "Running" appear for a few second. But I after a few second the word "Running" disappear and Apache doesn't run. The image of the problem is following. I want to know how can I activate Apache on xampp.

SHARE
Best Answer by trivis caat
Answered By 0 points N/A #128634

Why my apache of xampp is not working?

qa-featured

Yes this the same problem occur to many people while they are running Apache from xampp. This error is because on the port number which operate on Apache operates is busy and that's why the "Running" world appear for a few second and then disappear. what you have to do.

You have to disable all the services which are using the port. Normally Apache operates on port 80 and Microsoft IIS also use this port number. go to your start up services and disable this service. Now restart you Apache server and it will work. thanks

Best Answer
Best Answer
Answered By 0 points N/A #128635

Why my apache of xampp is not working?

qa-featured

Your Apache server is not working because the port 80 on which Apache is running is already in use and Apache can't get its control over. that's why it is not running. To start you Apache you have two methods 1) free the port on which Apache is running 2) change the port number of Apache from 80 to 81 or the number you want to according to your choice. to do the first Method click on SCM button in your xampp it will open all the services running search for the IIS because this service also use the same port and disable it. If you don't want to disable and want to Run Apache as well then go to the configuration file of Apache open it in any editor and search for port number 80 change it. save the changes and then restart your xampp. it will work and running but after changing the port number if you want to access your localhost then you have to write this " localhost:81/joomla " thanks

Login/Register to Answer

Related Questions