No of visitors who read this post: 1713
Category: Windows 7
Type: Question
Author: Beniamin
Your rating: None Average: 2 (1 vote)

I have a 4 GB pen drive. I am using it as a little drive for bearable software. When I copy my needed files from this pen drive, the files are not copied. There is a message shown as,"Read only file. Do not copy. Please tell the Microsoft etc."

Now how can I copy this file from my pen drive?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 18694

Hello,

Such type of problems is caused due to some settings of the file. Just access the pen drive and right click on the file and click on properties.  After clicking properties a window of properties will appear.  There you can see an option with check box “Read only”.  Make sure you uncheck it.

This problem could also be caused because  your USB drive may be locked or right protected.  There can be many reasons for it being locked. Try unlocking it and you will be able to copy the file. Thanks, Mark

# Comment Id: 18730

Hi Beniamin,

When you copy files from the pen drive, the read-only attribute is typically set for the files. When you use Windows Explorer to restore the files from the pen drive to the hard disk, the read-only attribute remains set for the files. Therefore, you cannot edit the file unless you manually clear the read-only attribute for it.

You can remove the read-only attribute from a file by following:

  1. In Windows Explorer, right-click the file that you want to change,  then click Properties.
  2. On the General tab, click to clear the Read Only check box.
  3. Click OK.