Volume D: was not defragmented. Reason: The volume is read-only

Asked By 10 points N/A Posted on -
qa-featured

Hi Experts,

I have been trying to defrag all my drives and i get the below message in my Application event logs. Can anyone help.

 

Log Name:      Application
Source:        Microsoft-Windows-Defrag
Date:          1/5/2012 7:47:51 AM
Event ID:      12289
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      XYZ
Description:
Volume D: was not defragmented. Reason: The volume is read-only
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-Defrag" />
    <EventID Qualifiers="0">12289</EventID>
    <Level>3</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2012-01-05T02:17:51.000Z" />
    <EventRecordID>70329</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Dev-chen-pc0306.ibahealth.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>D:</Data>
    <Data>The volume is read-only</Data>
  </EventData>
</Event>
 
Regards
SHARE
Best Answer by Drianna allen
Answered By 0 points N/A #116957

Volume D: was not defragmented. Reason: The volume is read-only

qa-featured

hi!

I think this is the solution of your problem

First- You just open(My Computer) and right click on Volume (D:) and then go down to properties 

then small windows comes out then click on Security.

second- Click edit on the center and check Full Control (allow box)and click (apply) then press OK,,

then try to run again the defragment tools..

Thank you..

 

Best Answer
Best Answer
Answered By 0 points N/A #116958

Volume D: was not defragmented. Reason: The volume is read-only

qa-featured

Hi Qammy,

The problem is that you do not have the right permissions to write on the drive, and hence you cannot use the defragmentation feature. Make sure you have the permissions and that you are logged into from an administrator account. Once you have made sure, go to the properties of the drive, and uncheck the read-only option. Once you have done this, re-run the defragmentation tool, it should work fine for you.

Hope this helpes!

Drianna allen

Login/Register to Answer

Related Questions