VirtualBox Critical Error – Looking for Solution

Asked By 20 points N/A Posted on -
qa-featured

Hi all

I doubt what is the reason this error. Just I run VirtualBox software after installation.

Then I tried to install again, repairing, trying to upgrade version, and also downgrading version.

However, I get this error.

Please help me.

VirtualBox – Critical Error

Failed to create the VirtualBox Com object.

The application will now terminate.
 
Details
 
Callee RC:        REGDB_E_CLASSNOTREG (0x80040154)
 
                    OK            Copy

Thanks in advance.

SHARE
Best Answer by Carl Jack
Best Answer
Best Answer
Answered By 0 points N/A #152721

VirtualBox Critical Error – Looking for Solution

qa-featured

Hello Ney,

To resolve the Virtual Critical Error, you will need to try the following workarounds:

Solution 1

Run the following command: sudo dpkg -P virtualbox-3.1 and see if it might help.

The problem may be occurring because you have got residual configurations for the old version on your system.

When typing the above command, make sure that you do NOT change the commands or you may end up break your operating system. Linux OS is very case sensitive; you make sure you stay accurate. I will prefer if you just copy and paste the command in the command prompt.

Solution 2

  • On your computer, go on System and then choose Administration.
  • Next select the Synaptic (Packet Management), and then choose the package virtualbox.
  • Make sure that the Virtualbox you choose is not virtualbox-ose for it seems you use version from VirtualBox.
  • After that uninstall.
  • Next thing will be either to reinstall VirtualBox 3.1, or you can go ahead and install VirtualBox 4

Regards,

Carl

Answered By 0 points N/A #152722

VirtualBox Critical Error – Looking for Solution

qa-featured

Have you tried to uninstall and reinstall it back?

Another workaround is to download the latest version of .NET Framework and see if it will work.

It seems that there is something missing in your computer that requires Virtual Box to run correctly so I would really suggest downloading the correct version of Virtual Box and then install it again.

Also, does your UAC disabled?

Your Virtual Box may be is trying to register a COM object with your operating system without administrative privileges.

Try running it as the administrator and enable your UAC.

Answered By 10 points N/A #152723

VirtualBox Critical Error – Looking for Solution

qa-featured

To fix this issue the best way is use the latest version of VirtualBox. Also before installing the VirtualBox run a Repair disk permission using Disk Utility. There is another Techyv’s thread which is describes about this issue. Pay a visit that page and get more way to fix this issue.

Virtualbox – Failed to create the VirtualBox COM object

Login/Register to Answer

Related Questions