Unable to Stop or Block Unwanted Pop-ups

Asked By 0 points N/A Posted on -
qa-featured

I am using Google Chrome. Whenever I click on a particular link, my page starts loading slowly and a lot of pop-ups prevent me from accessing it. I don’t know how to prevent this. Please help me with a probable solution.

SHARE
Answered By 0 points N/A #97654

Unable to Stop or Block Unwanted Pop-ups

qa-featured

Open the Chrome Browser from your desktop icon. You can follow the simple steps mentioned below. :

  1. Click the Chrome menu from top corner of the taskbar.
  2. Click on Settings.
  3. Click on Show advanced settings.
  4. Under the "Privacy," button, click on Content settings. You will find a “Pop-ups” option.
  5. From the "Pop-ups" option, select the recommended settings or "Allow all sites to show pop-ups".

With this, you will have blocked all pop-ups that might have cropped up on your screen while browsing through Chrome.

Login/Register to Answer

Related Questions