Ubuntu 10.10 is pops up with an error message

Asked By 20 points N/A Posted on -
qa-featured

Hi,

I am running Ubuntu 10.10 and there is a sudden error that pops up with the message “Desktop effects could not be enabled”. Any ideas?

Error on Ubuntu 10.10

Desktop effects could not be enabled

SHARE
Answered By 562865 points N/A #174143

Ubuntu 10.10 is pops up with an error message

qa-featured

If you are running your computer with an NVIDIA video card, try doing these to fix the desktop effects problem. First, backup “xorg.conf” by running this command without quotes in the terminal:

  • “sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup”

In case an error was encountered after doing it, run this command without quotes to restore it:

  • “sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf”

Download the latest NVIDIA driver. For computers with AMD64, you can use the command without quotes to download the latest NVIDIA driver:

  • “wget http://us.download.nvidia.com/XFree86/Linux-x86_64/190.42/NVIDIA-Linux-x86_64-190.42-pkg2.run”

If you have an i386 computer, use the command without quotes to download the latest NVIDIA driver:

  • “wget http://us.download.nvidia.com/XFree86/Linux-x86/190.42/NVIDIA-Linux-x86-190.42-pkg1.run”

Wait for the download to complete.

You may also download the driver by visiting Unix Driver Archive. When the download is complete, run this command without quotes. Remember to replace the filename with your file’s name:

  • “chmod u+x NVIDIA-Linux-x86_64-190.42-pkg2.run”

Next thing to do is to install the compiling tool by running the command without quotes:

  • “sudo apt-get install linux-headers-$(uname -r) build-essential”

If in case you installed the old version of the driver, go to Applications, Ubuntu Software Center, Installed Software, search for nvidia and then remove the old driver. After that, run the command without quotes:

  • “sudo apt-get autoremove”

Close gdm and then press CTRL + ALT + F1 then login from tty1.

When entering the password to login and it contains numbers, use the normal number keys instead of the number pad on the right of the keyboard. After logging in, enter this command without quotes to close the server:

  • “sudo /etc/init.d/gdm stop”

Use these commands to delete old video card drivers:

  • sudo rmmod nvidia​
  • sudo rm -r -f /lib/modules/$(uname -r)/kernel/drivers/video/nvidia

After doing these, change 2.6.31-14-generic to your Ubuntu kernel version. Next, install the newly downloaded driver using the command without quotes:

  • “sudo ./NVIDIA-Linux-x86_64-190.42-pkg2.run”

Start gdm again using the command without quotes:

  • “sudo /etc/init.d/gdm start”

Finally, check the configuration by navigating to System, Preferences, NVIDIA X Server Settings.

Login/Register to Answer

Related Questions