TeamViewer error asks to update program

Asked By 20 points N/A Posted on -
qa-featured

Hello there,

This morning this error appeared when I tried to connect to my cousins PC. I would like to make the necessary updates but as you can see in the error image I am asked to update my software. Can anyone help me with this error? Is it necessary to do so?

TeamViewer
Your partner uses a newer vresion of TeamViewer. Would you like to update TeamViewer now to establish a connection?
No

Thanks!

SHARE
Answered By 560815 points N/A #187962

TeamViewer error asks to update program

qa-featured

Yes, you’re right. Though it asks you if you want to update your application but the dialog box itself doesn’t have the option to begin the update. It should also include the Yes button instead of just the No button. But even if this is the case, there is really no problem even if the dialog box doesn’t provide an option to update.

You can always do the update manually. This means both TeamViewer clients should have the exact version before you can establish a connection and if you don’t update you will not be able to connect to the other computer. Download the latest version from TeamViewer 9.0.27614 for Windows. It supports Windows XP, Windows Vista, Windows 7, and Windows 8.

For Mac users, you can download the latest version from TeamViewer 9.0.27339 for Mac. It supports Mac OS X 10.6 Snow Leopard and higher. It is also available in Linux and mobile versions. Uninstall your current version then restart your computer. Install TeamViewer 9.0.27614 or 9.0.27339 depending on your operating system and then connect to your cousin’s computer.

Login/Register to Answer

Related Questions