Synchronization has failed in Sage ACT! 2012

Asked By 0 points N/A Posted on -
qa-featured

This is the error I found with Sage ACT! 2012 "Synchronization has failed.  Cannot insert duplicate key row in object sys.syscommittab with unique index 'si_xdes_id'.  I cannot even check the error log since it’s terminated. What can I do?

SHARE
Best Answer by muhammadullahc
Best Answer
Best Answer
Answered By 0 points N/A #103757

Synchronization has failed in Sage ACT! 2012

qa-featured

It’s problem with Microsoft® SQL Server® 2008 R2. This issue can be resolved by running those files.
use SQL2008R2_Express_BackupFix.bat
use SQL2008R2_Standard_BackupFix.bat

I will give the link to install those bat file.

      Before following the steps below make sure that the SQL ACT7 is running.


To run this file:

  1. Click on the appropriate file below, and choose the Save option. Save it to your desktop.
  2. Close Sage ACT!
  3. Find the file you downloaded and double-click on it to run it. When prompted, you will type in the name of the database in which you are experiencing the error.
  4.  If you do not know the name of your database, then open Sage ACT! in look in the upper left corner of the screen – the name of your database will be after the Sage ACT! Product name.
  5. After the file runs, click your Windows® Start button, and on the Start menu> go to the Search box at the bottom of the Start menu. Type in services.msc.
  6. In the list of services, locate SQL Server (ACT7).
  7. Right-click on this service and select Restart. Close the services window.
  8. Reopen Sage ACT! and make a backup of your database to test.

More information:

If you can’t run the batch file, you may be able to resolve using the following steps:

  1. Copy the batch file you have downloaded.
  2. Open Windows® Explorer and browse to the following directory: C:Program FilesMicrosoft SQL Server100ToolsBinn.
  3. Paste the batch file in the "Binn" folder.
  4. Double-click the batch file to run it from this location. When prompted, you will type in the name of the database in which you are experiencing the error. If you do not know the name of your database, then open Sage ACT! in look in the upper left corner of the screen – the name of your database will be after the Sage ACT! product name.
Answered By 0 points N/A #103759

Synchronization has failed in Sage ACT! 2012

qa-featured

The recent ACT! Diagnostics Utility (ACTDiag) has a repair option that can fix this error. Simply follow the workarounds below:

1. Download the file ACT! Diagnostics_v15.0.288 and install it on your computer.

2. Close all the active SQL applications running in your computer.

3. Run the downloaded ACT! Diagnostics Utility.

4. Select Databases and then Database List on the ACTDiag.

5. Find your database on the list and then click the box to highlight it.

6. Select Actions and then Syscommittab Repair and click OK.

7. Wait for the confirmation stating that the repair succeeded.

8. Open Sage ACT! and try to run it again.

Login/Register to Answer

Related Questions