Softlock License Manager Error when opening AutoCAD 2012

Asked By 20 points N/A Posted on -
qa-featured

The error I posted below is showing when I opened AutoCAD 2012.

When searching online, I found a similar story and the cause of the error is an issue with file or folder permissions.

I used Windows XP Media Center Edition Ver. 2002 SP3.

What is the solution for this?

AutoCAD

The security system (softlock license manager) is not functioning or is improperly installed.

SHARE
Best Answer by Joe Ann
Best Answer
Best Answer
Answered By 0 points N/A #94340

Softlock License Manager Error when opening AutoCAD 2012

qa-featured

I think this is characteristically a file / folder permissions matter. You require to provide complete rights authorization to the everybody group on the certain folder and its files. On windows XP  

C:Documents and SettingsAll UsersApplication Data FLEXnet

 On one occasion the access has been provided to the incorporated adskflex_…data files, it should launch lacking error.

These files are encrypted & essentially maintain established information.  Kindly attempt allow all with full control permissions to the folder and move adskflex data files you locate there to new folder (e.g. Desktop). If work is not done, immediately erase the files.Cannot delete the files? It means that the service that needs those files is still in utilize.

Move to the services.msc and see for “FLEXnet Licensing Service” and “FLEXnet Licensing Service 64″. Launch the service, subsequently stop the service – in that order. Just the once those services are stopped, delete those two files and begin the services up again. Start AutoCAD and enjoy. 

Answered By 0 points N/A #94341

Softlock License Manager Error when opening AutoCAD 2012

qa-featured

Hello Julia,

The error that you are getting is due to a corrupted installation of an Autodesk program or maybe a registry tweak to alter the license method from Network to Standalone. To resolve that issue, you will need to try the following workarounds:

  • Try performing a clean uninstall and after that reinstall the Autodesk Program.
  • If that does not fix the issue, you will need to delete the license file and then re-activate the software.
  • To get the license files, check the following folders:
  • For Vista or Windows 7: C:ProgramDataFLEXnetadskflex_00691b00_tsf.data, or C:ProgramDataFLEXnetadskflex_00691b00_tsf.data.backup
  • For Windows XP: C:Documents and SettingsAll UsersApplication DataFLEXnetadskflex_00691b00_tsf.data, or C:Documents and SettingsAll UsersApplication DataFLEXnetadskflex_00691b00_tsf.data.backup
  • In the event

If the issue persists, then it is most likely that it is related to the user permission, so you will need to try to installing and then running the software as a local administrator account.

Regards,

Carl

 

Answered By 70 points N/A #94343

Softlock License Manager Error when opening AutoCAD 2012

qa-featured

This problem is because of some services and registries. May be the licensing services are disabled or Autodesk program’s corrupted installation or the trusted storage files are corrupted or the installation or production is corrupted etc. causes occur this issue. To solve this problem check and be sure that the services are not disabled:

1. Go to Windows Start option >> in the Run box type “Services”.

2. Select “Services”  node.

3. From services list, trace “FlexLM Licensing Service" and "FlexLM Licensing Service 64”.

4. Right-click the entry and select “Properties”.

5. Now set the “Startup Type” to “Automatic”

6. To start the service Click on “Start” >> then click “OK”.

7. Now start the program to test.

Note : Do this for both services ( 32 bit systems may have only one service)

If no luck, need to move data file or performing a clean uninstall & reinstall of the program should solve the problem.

  • To move a data file:

1. Search for a specific …”TSF.data” file, example “ADSKFLEX_NUMBERS_TSF.data”.

Location in Windows XP:

Documents and SettingsAll UsersApplicaStartup Type tion DataFLEXnet

Location in Vista and Windows 7:

C:ProgramDataFLEXnet

2. Change the file extension like “ADSKFLEX_NUMBERS_TSF.data.BAK”.

3. Now start the program. A new TSF DATA file will be created.

4. If the program works, you are done but if not delete the new TSF.DATA file and the log. Restore the original file to the original location.

5. Start the software and register the software as requested.

  • To uninstall the program follow one of the methods:

1. Visit the site to uninstall the program and remove the trusted storage as describes in the topic.

2. For a clean uninstall use one of the method which is described in this post.

3. Uninstall utilizing the Microsoft install or uninstall Fixit Utility.

  • Now reinstall the software:

1. Verify that you have full authorization to these location before starting

Registry Entries:

HKEY_CURRENT_USER>SOFTWARE>AUTODESK

HKEY_LOCAL_MACHINE>SOFTWARE>AUTODESK

Folders:

The folder the software was installed in, such as, “C:program filesAutodeskAutoCAD 2013”.

Windows 7 and Vista:

C:ProgramDataAutodesk

C:Users<the current user>AppDataLocalAutodesk

C:Users<the current user>AppDataRoamingAutodesk

C:Program FilesCommon FilesAutodesk Shared

C:ProgramDataFlexnet

C:ProgramDataAutodeskAdlmProgramInformation.pit

2. Be sure the UAC and antivirus are inactivate then right-click on setup.exe and run the install using the “Run as Administrator” option.

3. Launch the program and let the activation to proceed.

Answered By 563960 points N/A #275698

Softlock License Manager Error when opening AutoCAD 2012

qa-featured

When launching Autodesk AutoCAD, you might encounter one of the following errors:

  • “Unable to initialize ADLM”
  • “The security system (Softlock license manager) is not functioning or is improperly installed”

If this happens, here’s what you should do. Check if the services required by AutoCAD are running and are not disabled. Click “Start”, “Control Panel”, “Performance and Maintenance”, “Administrative Tools”, and then double-click “Services”. In the list of services, look for “FlexLM Licensing Service” and “FlexLM Licensing Service 64”. If you are using 32-bit Microsoft Windows, you might see only one of these services.

Right-click on one of the service and select “Properties” or simply double-click it. In “Startup type”, set it to “Automatic”. Next, click “Start” to start the service and then click “OK”. Do this for both services if you have them. Start AutoCAD again then see if it works. If that doesn’t fix it, you need to try moving a data file.

Open Windows Explorer then navigate to the following locations:

For Microsoft Windows XP:
C:\Documents and Settings\All Users\Application Data\FLEXnet

For Microsoft Windows Vista and Microsoft Windows 7:
C:\ProgramData\FLEXnet

Look for a particular xxx_TSF.data file, something like “ADSKFLEX_NUMBERS_TSF.data”. Rename the file but don’t delete it. After this, start AutoCAD. It should automatically create a new xxx_TSF.data file. See if it runs successfully.

Login/Register to Answer

Related Questions