[Silverlight] Desktop does not recognize Silverlight installation

Asked By 0 points N/A Posted on -
qa-featured

I installed Microsoft Silverlight 3 (3.0.40723.0) on my desktop but it does not get recognized.

Is it absolutely necessary to have the latest version of Silverlight?

SHARE
Best Answer by Sharath Reddy
Answered By 0 points N/A #96047

[Silverlight] Desktop does not recognize Silverlight installation

qa-featured

Hi Melendezathena,

You may want to check the version of your Internet explorer and make sure you are running a 32 bit version of it. Microsoft Silverlight seems to be only running on a 32 bit Internet Explorer. If you are using a 64 bit Windows 7 computer, it usually have the 32 and 64 bit Internet explorer. So you just need to make sure you are running on the 64 bit. You also need to make sure it is installed and save on the program files where all 32 bit applications are installed.

You can go here http://www.microsoft.com/getsilverlight/get-started/install/default.aspx to download the latest version of Silverlight.

Aristono

Best Answer
Best Answer
Answered By 563960 points N/A #96048

[Silverlight] Desktop does not recognize Silverlight installation

qa-featured

I think you are successful in installing Silverlight on your computer. It’s just that the program doesn’t get recognized with the browser you are using. Silverlight is actually designed to run on Microsoft Windows and Mac OS X. For users running Microsoft Windows, you should be using Windows Server 2003 Service Pack 2, Windows Server 2008 R2 Service Pack 1, Windows Server 2008 Service Pack 2, Windows Server 2012, Windows XP Service Pack 3, Windows Vista Service Pack 2, Windows 7, Windows 7 Service Pack 1, Windows 8, and Windows 8.1.

For users running Mac PC, it supports Mac OS X 10.5.7 Leopard and higher. Silverlight supports only these web browsers: Microsoft Internet Explorer, Mozilla Firefox, Safari, and Google Chrome. Here is the breakdown of Silverlight based on supported web browsers. For Google Chrome users, it should be in version 12 and higher and it supports all mentioned operating systems except Mac OS X.

For Safari, it should be in version 4 and later and is limited only to Mac OS X. For Mozilla Firefox, it should be in version 12 and higher, and it supports all mentioned operating systems. Microsoft Internet Explorer 6 is not included in the supported web browser. For Microsoft Internet Explorer 7, it is limited only to Windows Server 2003 Service Pack 2, Windows XP Service Pack 3, Windows Vista Service Pack 2, and Windows Server 2008 Service Pack 2.

For Microsoft Internet Explorer 8, you should be running Windows Server 2003 Service Pack 2, Windows XP Service Pack 3, Windows Vista Service Pack 2, Windows Server 2008 R2 Service Pack 1, Windows Server 2008 Service Pack 2, Windows 7, and Windows 7 Service Pack 1. For Microsoft Internet Explorer 9, you should have Windows Vista Service Pack 2, Windows Server 2008 R2 Service Pack 1, Windows Server 2008 Service Pack 2, Windows 7, and Windows 7 Service Pack 1.

For Microsoft Internet Explorer 10, your computer should be running with Windows 7 Service Pack 1, Windows Server 2012, and Windows 8. For Microsoft Internet Explorer 11, you should have Windows 7 Service Pack 1 and Windows 8.1.

Login/Register to Answer

Related Questions