Sharp AR-C330 suddenly stopped responding

Asked By 0 points N/A Posted on -
qa-featured

Hello,

I have some problems with my Sharp AR-C330 copier. When I was trying to give it a command to copy, it suddenly stopped copying and gave me an error message showing error code F2-54.

I tried to change the cartridge but it didn’t solve the problem.

Do you have any idea about what the problem is and its appropriate solution?

Kindly suggest to me the ways on how to solve this.

Thanks in advance.

SHARE
Answered By 0 points N/A #148289

Sharp AR-C330 suddenly stopped responding

qa-featured

Hi Carlos Blakke,

I understand that you are having a problem using your Sharp AR -330 Copier. 

In lieu of your query re: error code f2-54-

Please try and do the following steps and hopefully you can have it working again in no time.

Try to reboot the printer, if this doesn't work,

Try to clean the metal contacts gently that connects the cartridge to the printer & its drum surface. Use a cleansing solution for electronics. 

If this still doesn't work. You would need to have the manufacturer replace the OPC drum. 

I hope I was able to help 

Sincerely,

Paul Pinalb

 

Login/Register to Answer

Related Questions