Server running only on localhost, cannot view remotely

Asked By 240 points N/A Posted on -
qa-featured

Hi,

I have an Apache server running on my local. When I type local host on my browser I can see the "It works" page. But when I give my IP to other people they can't see a thing, says server not found.

How do I solve this?

SHARE
Best Answer by peace
Best Answer
Best Answer
Answered By 0 points N/A #85995

Server running only on localhost, cannot view remotely

qa-featured

Hi Lenia,

To disable the firewall portion of Windows Firewall from a command prompt:

1. Open Command Prompt (Press Windows icon along with ‘r’ and type cmd and press enter).

2. You can also open by clicking Start, click All Programs, click Accessories, right-click Command Prompt

3. At the command prompt, type the following command: netsh advfirewall set profiles state off where profiles is AllProfiles, CurrentProfile, DomainProfile, PrivateProfile, or PublicProfile.

To disable Windows Firewall by using the Windows Firewall Control Panel program:

1. Click Start — Control Panel — Network and Internet, and then under Windows Firewall, click Turn Windows Firewall on or off.
2. On the General tab of the Windows Firewall Settings dialog box, select Off (not recommended), and then click OK.

To disable Windows Firewall with Advanced Security by using the Windows Firewall with Advanced Security snap-in:

1. Click Start — All Programs — Administrative Tools, and then click Windows Firewall with Advanced Security.
2. In the navigation pane, right-click Windows Firewall with Advanced Security on Local Computer, and then click Properties.
3. On each of the Domain Profile, Private Profile, and Public Profile tabs, change the Firewall state option to Off (not recommended).
4. Click OK to save your changes.

If you do not want to disable Firewall you can add exception for the web server as Follows:

1. Click Start, click All Programs, click Administrative Tools, and then click Windows Firewall with Advanced Security.
2. Click on Advanced tab
3. Click on Settings and select Web Server (HTTP) or Secure Web Server (HTTPS)

This should resolve your issue.

Regards,

Prashanth

Answered By 0 points N/A #85999

Server running only on localhost, cannot view remotely

qa-featured

Hello Lenia,

The reason why other people cant see your site or page is that your computers current host file configuration is only at the localhost. Of course, if they try to ping your IP address it would return a signal but couldn't view your page. This means that your IP address is not  encoded to your host file.

Navigate your host file at C:WINDOWSsystem32driversetc.  Open the host file to the text editor or just double click and select programs to open the file and choose notepad. Once the file is open, add your IP address and Computer Name by simply following the localhost format ex :   192.168.2.3  ComputerName.

Encode it next to the localhost and then save and exit then restart your Apache.

Login/Register to Answer

Related Questions