Savage 2 Upgrade Problems in Ubuntu Linux

Asked By 20 points N/A Posted on -
qa-featured

Hello, I got a Ubuntu Linux and installed it in my PC and proceeded to set up "Savage2". 

Later when I logged in there was a dialog box that indicated to go ahead and upgrade to 2.1.0 .5 from 2.1.0.2.

However this did not work, I cannot start the game so I restored it back to 2.1.0.2.

Can anyone point me to the right direction on how to install it properly in Linux?

Thanks.

SHARE
Answered By 560680 points N/A #102478

Savage 2 Upgrade Problems in Ubuntu Linux

qa-featured

There is no problem with the operating system you are using. The problem maybe originated when you tried upgrading the game to the latest version. This is usually a normal error and nothing to worry about.

If you are having a problem upgrading Savage 2 from version 2.1.0.2 to 2.1.0.5, just uninstall the older version installed on your computer and then download the latest version that is available in the website.

Savage 2 – A Tortured Soul system requirements:

Windows

  • Pentium 4 2.2GHz, AMD 2000+ or faster processor recommended
  • Windows 2000, Windows XP, Windows Vista
  • 1 GB RAM or higher recommended
  • 128 MB video card, Nvidia GeForce, Radeon or higher recommended
  • DirectX 9.0
  • Internet connection required

Linux

  • Pentium 4 2.2GHz, AMD 2000+ or faster processor recommended
  • 1 GB RAM or higher recommended
  • 128 MB video card with OpenGL 2.0 or GLSL 1.20, Nvidia GeForce, Radeon, or higher recommended
  • Internet connection required

OS X

  • Faster Intel processor
  • 1 GB RAM or higher recommended
  • 128 MB video card with OpenGL 2.0 or GLSL 1.20, Nvidia GeForce, Radeon or higher recommended
  • Internet connection required

Video cards supported:

  • OS X 10.4: GeForce 8600, Radeon HD 2400 or higher
  • OS X 10.5: GeForce 7300, Quardo FX 4500, Radeon X1600 or higher

Doesn’t support Integrated Intel GMA 950 / X3100.

Login/Register to Answer

Related Questions