Safelist option in Office Outlook is not working

Asked By 430 points N/A Posted on -
qa-featured

I enabled the “Safelist Only” option in Office Outlook by clicking on Tools>Options>E-mail>Junk E-mail and then checked the Safelist Only.  This is to filter those incoming spam and junk mails that is not on my safe senders list.  But the amount and nature of SPAM did not change. Is there a way that I can change it? 

SHARE
Best Answer by Mcdonald Larimore
Answered By 0 points N/A #106814

Safelist option in Office Outlook is not working

qa-featured

Hello Erin,

Did you try editing the images and blocking the user names? Just show the domain names and check. Also check your Junk mails and just add their address or domains to "Blocked" category. Safelist is basically stored centrally in Microsoft Exchange and this issue is probably due to the internal domains or the internal domain users missing from Safelist. Also a junk mail can create this problem so try deleting them and then recreate Outlook and am sure it will work. Good Luck,

Thanks!!

Best Answer
Best Answer
Answered By 0 points N/A #106815

Safelist option in Office Outlook is not working

qa-featured

Hello Erin111,

The type of change that you made, need more than just changing settings, to be effective. Changing the settings and applying them are two different things. What you did was changing the settings, in order to apply them and make them effective you were supposed to close the program (MS Outlook) and then re-open it after making changes in the settings and then the program would open with new settings applied and fully working. Do it, and the changes you made, will be effective.

Login/Register to Answer

Related Questions