Remote desktop problem with Ubuntu 10.10 laptop

Asked By 200 points N/A Posted on -
qa-featured

Hi,

I don't know if I'm posting in the right area as I could not find any Linux category.  So, I guess this is the right place. I am facing problem while trying to remote desktop my windows 7 pc from my ubuntu 10.10 laptop. I can never get things full screen and can't even scroll. I've been using the remote desktop client and terminal sever client, neither doing the trick. Can anyone help?

SHARE
Best Answer by savage_god
Answered By 0 points N/A #86603

Remote desktop problem with Ubuntu 10.10 laptop

qa-featured

Hey there,

It's normal to have problem if you are using the default remote desktop server provided with windows knowing how they like(!) each other! Install a vnc server on your windows machine like tight vnc which is free  and see if that solves your problem! Cheers!

Answered By 0 points N/A #86605

Remote desktop problem with Ubuntu 10.10 laptop

qa-featured

Hey,

I agree with Savage on this but I suggest you use other vnc viewer for that vnc server you are going to install on the windows machine. The terminal server client will work as well after changing the protocol to vnc! Best of luck with your remoting. Good day!

Answered By 200 points N/A #86606

Remote desktop problem with Ubuntu 10.10 laptop

qa-featured

I have done as you said but could not make things work. When I try to connect with terminal server client it says "connection failed". I have set the port 5900 as required (got the info from Google) but still is doesn't work! Help please!

Best Answer
Best Answer
Answered By 0 points N/A #86608

Remote desktop problem with Ubuntu 10.10 laptop

qa-featured

You didn't mention what sort of connection you are using. Seeing that they are both your computer , I am assuming you are on a local network using router. In that case you will have to do some port forwarding. Assuming that you have administrator privilege on your router:

      1. Go to the control panel of your router (should be something like 192.168.*.*, see manual).

      2. Find the section named "Forwarding" or "triggering".

      3. Click "add new" or "new rule" or something like that".

      4. In the service port field, put 5900 and in the IP address field, put the IP address of your windows machine.

      5. Save and enable.

Enjoy!

Answered By 0 points N/A #86609

Remote desktop problem with Ubuntu 10.10 laptop

qa-featured

Using terminal server client for vnc connections is not a very good idea and could arise problems. I would recommend that you use applications like gtk vnc viewer. Just go to application center on your Ubuntu and search with the keyword "vnc" and you'll find what you need! Hope this helps!

Answered By 200 points N/A #86610

Remote desktop problem with Ubuntu 10.10 laptop

qa-featured

Thank you guys, that forwarding worked like a charm! Thanks to both of you!

Login/Register to Answer

Related Questions