Realtek adapter problem: loosing internet connection every now and then

Asked By 10 points N/A Posted on -
qa-featured

I use Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC.

For the last few days I'm having a problem in which my card works for, like, 10 minutes and stops and I loose internet connectivity.

I have tried to update the driver and also rolling it back, but I won't work.

SHARE
Answered By 562865 points N/A #115591

Realtek adapter problem: loosing internet connection every now and then

qa-featured

I’m not sure if your network card’s current location in the CPU, the slot that it is currently attached to, is affecting this problem. You may try to transfer the card to the next available slot and then try your internet connection again and see if there is a difference. Be sure to turn off your machine before opening up your CPU and removing the network card from the slot to avoid any damage to the hardware.

You may also try unplugging your cable modem from the computer then restart Windows. Wait for Windows to finish booting before plugging in again the cable modem. Try to connect again and see if you have a stable connection now. You may also check your modem if its light is flashing or is turned off. If this is the case, it is possible that there is a problem with the wiring between your home and the cable company. Try contacting them for support.

You may also try downloading WinSock XP Fix. Unfortunately, this version only works for Windows XP platforms.

Download and run this application. When the program starts, backup your registry first by clicking REG Backup.

Wait for it to finish then click Fix. Restart your computer then check your internet connection again.

Login/Register to Answer

Related Questions