Problem in TFS Build Service Dependencies

Asked By 10 points N/A Posted on -
qa-featured

H! Is there anyone who has had to deal with services failing to start (i.e. logon permissions, setting recovery responses [run a program], verifiying dependencies, etc.) knows what a real PITA it can be to track down the culprit of the failure. Having said that I recently had an issue with the "Visual Studio Team Foundation Build Service Host" service, a message box that stated “Cannot start service TFSBuildServiceHost on computer ‘contoso.na.microsoft.net'. (The dependency service or group failed to start)” was promptly displayed when trying to start the service. The service in question is shown on  the image below :

Thanks as to anyone who can help.

SHARE
Answered By 0 points N/A #136659

Problem in TFS Build Service Dependencies

qa-featured

Hello Theresajmickens,

This is a very important problem, the solution to which is needed to know by most people dealing with such case. This is a case of dependencies. This problem either happened because the Remote Access Connection Manager is either disabled or its associated devices are not enabled. Go and check through the event log and if you find the Remote Access Connection Manager in a disabled mode, set it to an automatic start and then look for the Telephony if it is disabled, then enable it. This will help solve the problem and you will be able to work on the TFS build service

Hope your problem gets solved. Best of Luck.

Login/Register to Answer

Related Questions