Ports 80 or 443 SSL already in use. XAMPP Error

Asked By 110 points N/A Posted on -
qa-featured

Hi Dears,

I am using Windows 7 Ultimate. Now i try to install XAMPP software at this operating system but when i install it then i receive below error. Please tell me how can i solve it. Tell me with screen shots so that i can understand solution easily.

If you know proper answer and can tell me in easy steps only then give me answer.

Regards,

 

XAMPP 1.7.7 win32

Ports 80 and 443 (SSL) already in use! installing apache 2.2 service failed!

SHARE
Best Answer by ICANHELP
Best Answer
Best Answer
Answered By 0 points N/A #83779

Ports 80 or 443 SSL already in use. XAMPP Error

qa-featured

Simple answer. Do you have Skype installed?

If yes then

Open Skype > Tools > Options > Advanced > Connections

There will be a checkbox

 “Use port 80 and 443 as alternatives for incoming connections”

Just Uncheck and save changes

If this does not fix. Reply back

We are here to help

Answered By 0 points N/A #83780

Ports 80 or 443 SSL already in use. XAMPP Error

qa-featured

Xampp is a server software and it used the mentioned port 80 and 443 as the default ports when you install it. In this case, it seems that some other application that you have installed on your computer already uses the ports that have been mentioned, and the possible applications will be:

  • A mail server that you have installed on your computer, like outlook express.
  • Internet Information service is enabled on your computer.

To use Xampp, you will need to do the following:

  • Shut down the application that is using port 80, in case you are not using that application right now.
  • Change the port for xampp to another port.

Regards
Thompson Locker

 

Answered By 0 points N/A #83781

Ports 80 or 443 SSL already in use. XAMPP Error

qa-featured

Hi there. This is not actually a solution but a follow-up of the problem above. I just don't know where to fill up a follow up question so I use this one, my apology.

I have exactly the same problem with that "Port 80 or 443…" error. But none of those recommendations work.

I logged on Skype and unchecked the port 80 box connection. It didn't work.

I uninstalled xampp, then uninstalled skype, and installed xampp again, still no luck.

(I just don't know how to configure IIS, but as I see how it works, as long as port 80 is free, or shutting down anything that uses port 80, apache should work.)

Somebody somewhere advised to run xampp_portcheck.exe so I know what's using port 80. When I run it, result says: (Service): Apache <HTTP> (Port): 80  (Status): Process System. After all, its apache that;s using it. Why is it not running in xampp?

(Even if I uninstall xampp, the same result will show if I run xampp_portcheck.exe. Does this mean I could have an old version of apache still running? )

Please help me as I've been looking around answers for days and nothing worked. 

Login/Register to Answer

Related Questions