PHP versions 5.5 and later do not support windows XP

Asked By 0 points N/A Posted on -
qa-featured

Hello,

I have installed on my PC PHP5.5 and when I tried to run the program this error appeared on my desktop. On the website it said that is compatible with Windows XP SP3 and 2003 but it seems like is not. I think it should work but the problem is with my Windows XP. Can anyone help to solve this error please ? Why is not compatible with my Windows even on the website it says it is ?

Thanks !

There has been an error.

PHP versions 5.5 and later do not support windows XP or windows 2003.You will need to install a different version of BitNami Ghost Stack that includes version 5.4 or earlier.

SHARE
Answered By 567105 points N/A #182752

PHP versions 5.5 and later do not support windows XP

qa-featured

If you can’t install PHP 5.5 because you are using Microsoft Windows XP, I’m not sure if you still need to install Bitnami Ghost Stack like what the message says if you can install PHP 5.4. PHP 5.4 is available and can be downloaded separately from Bitnami Ghost Stack. The latest version of PHP is PHP 5.5.13 and because PHP 5.5 no longer works on Windows XP, it surely requires higher operating system.

Because you need a much older version for Windows XP, download PHP 5.4.29 x86 Non Thread Safe or PHP 5.4.29 x86 Thread Safe. If you wish to see all downloads, visit PHP Binaries and Sources Releases. The latest versions of PHP were created using VC9 or VC11 [Microsoft Visual Studio 2008 and Microsoft Visual Studio 2012 compiler respectively].

The new builds include enhancements in stability and performance. Because of this, you need to install some required software. PHP 5.4 is created using VC9. For 32-bit Microsoft Windows, you need to download and install Microsoft Visual C++ 2008 Service Pack 1 Redistributable x86. For 64-bit Microsoft Windows, download and install Microsoft Visual C++ 2008 Redistributable x64.

Login/Register to Answer

Related Questions