OpenOffice for database error – need help

Asked By 0 points N/A Posted on -
qa-featured

Hi,

I just got started in using OpenOffice for my database when this error message displayed. 

I downloaded OpenOffice from a website and I know I have JRE installed in my PC.  Can I just uninstall and reinstall Java?  Reinstallation might affect other software in my PC that uses Java. 

Please provide exact steps on how to install JRE so as not to ruin other software.

OpenOffice.org requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart OpenOffice.org

JRE required

OpenOffice.org requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart OpenOffice.org

SHARE
Answered By 0 points N/A #85549

OpenOffice for database error – need help

qa-featured

 

 

Rolling back to 1.6 build JRE is a work everywhere, but JRE 1.7 builds are wholly functional.

Necessities have a 32 bit Java Runtime Environment and right environment/path to the JRE bin. Oracle JRE installers too place duplicates of JRE into the C:Windowssytem32 directory–which can cause a 64-bit JRE to be used somewhat than a 32-bit JRE.

If you have this problematic, check the surroundings registered in javasettings_Windows_x86.xml in your per-user profile, e.g. C:Users<username>AppDataRoamingLibreOffice3userconfig.

The .xml configurations must equal the system JRE configuration. Tricky for folks has been an .xml that lists 1.6 JRE while they have upgraded to a 1.7 JRE build.

Explanation is to fixed PATH and JAVA_HOME variables, and deletes the javasettings_Windows_x86.xml allowing it to rebuild with defaults resolved after system PATH variable. Eliminating the JRE prints from C:Windowssystem32 helps assure correct JRE as recognized by PATH is used.

Login/Register to Answer

Related Questions