NTVDM CPU has encountered an illegal Instruction on Turbo C++

Asked By 0 points N/A Posted on -
qa-featured

Hey guys,

I am having problems with my Turbo C++. My computer is running on windows xp and when I try to operate it in full screen mode I get this error message:

The NTVDM CPU has encountered an illegal Instruction.

16 bit MS-DOS Subsystem

Turbo C++ IDE

The NTVDM CPU has encountered an illegal Instruction.

CS:9002 IP:ffe 1 OP:ff ff ff ff ff Choose ‘close’ to terminate the application.

                                Close                                     Ignore

Any ideas guys?

SHARE
Best Answer by Patrick b
Best Answer
Best Answer
Answered By 0 points N/A #123740

NTVDM CPU has encountered an illegal Instruction on Turbo C++

qa-featured

Hello Winnie.

NTVDM or NT Virtual DOS Machine is a Windows 16-bit subsystem that allows 16-bit applications to run in DOS mode. Basically, it makes Turbo C++ IDE think that it is running under MS-DOS. One common cause of the problem here is the NTVDM can sometimes get corrupted. But you can fix that by using the System File Checker that comes with windows XP.

Here's how to fix it with the SFC:

1. Press Start > All Programs > Accessories > Command Prompt. Right-click and select "Run as…".

2. "The following user:" and pick "Administrator" from the drop-down list. Enter the Administrator password. Press OK.

3. An administrator-level command prompt window will open.

4. Enter "sfc /scannow" at the prompt.

5. Let SFC do its magic and test if your IDE works.

Hope this helps.

Answered By 0 points N/A #123742

NTVDM CPU has encountered an illegal Instruction on Turbo C++

qa-featured

Hello again Winnie.

In my first post I suggested a way to solve your problem by fixing NTVDM. I mentioned that a corrupt NTVDM COULD be the reason for NTVDM crashing. However, you have to also consider that it could Turbo C++ IDE that is causing the problem. 16-bit applications sometimes misbehave while running under the 16-bit subsystem of Windows XP and later versions of Windows.

If you also consider that running Turbo C++ in Windows XP consumes a lot of CPU cycles (because it run in a subsystem and has to pass through several kernel processes) then I think another worthwhile solution is to simply replace Turbo C++ IDE with a new one.

Here are a couple of free Turbo C++ IDEs that work better under Windows XP:

Bloodshed Dev C++ – http://www.bloodshed.net/devcpp.html

Eclipse CDT – http://www.eclipse.org/cdt/

GNU C++/C Compiler – http://gcc.gnu.org/

Microsoft Visual C++ 2010 Express – http://www.microsoft.com/visualstudio/eng/products/visual-studio-express-products

Answered By 0 points N/A #123743

NTVDM CPU has encountered an illegal Instruction on Turbo C++

qa-featured

After installing your turboC follow the steps.

1) Go to TC directory and open BIN.
2) In "BIN" folder you can find "tc.exe". Right click on "tc.exe" and click properties (and make sure that do not click on shortcut of TC.exe).
3) In properties there should be a tab called "screen", In that you will find "usage" option. There Select "Window" option instead of "full screen".
4) Then click "OK".
5) Now click "TC.exe".
6) It will open in window mode, if you want you can change full screen mode by pressing "ALT + Enter".

Thanks.

Login/Register to Answer

Related Questions