Creative X-Fi Speakers not working on my Win 7

Asked By 200 points N/A Posted on -
qa-featured

Hi,

I do not have any sound coming out from my speakers. I checked that the speakers are correctly connected to my computer and that they are on. However there is no sound. Everything was working just fine yesterday. I took my pc off and when i turned it back on today it just did not have any sound.

I did see that there is a yellow exclamation mark in the Device Manager implying that the drivers are not installed but i do not understand how that can happen. I did download a driver for my sound card but it did not work. I still do not have any sound on my computer and the yellow exclamation mark is still there.  

My computer has a Creative X-Fi Titanium card and my computer has Windows 7 Ultimate installed.

Thanks!

SHARE
Best Answer by tass0731
Best Answer
Best Answer
Answered By 0 points N/A #120933

Creative X-Fi Speakers not working on my Win 7

qa-featured

Hi James,

If you still see an exclamation mark on your device then you should update them. Right-click on the device(s) with the exclamation mark and then choose to update the software. You will be given 2 choices for this, to download over the internet for the software or to look for the software on your computer. I suggest you download from the internet. Once the installation has finished, there should be no exclamation mark now. Try to check now if there are sounds.

If there are still no sounds, but there is no exclamation mark anymore, try to check the volume. If still nothing, check Start > Run > type "services.msc".

Look for the Windows Audio service and click it. Go to the General tab. The Startup type should be on Automatic, and if the Service status is stopped, start it.

Tanasis

 
Answered By 0 points N/A #120934

Creative X-Fi Speakers not working on my Win 7

qa-featured

Hi

How are you, hope fine

This is simple if you have an optional sound card then change its main PCI slot to another slot and check it resources form the device manager this issue is due to not driver files properly copied to hard disks uninstall all existing drivers and then reinstall it new driver if you face the right driver to installed then open the chasis of Your system and read the Chipset model or version and install the same version of your sound card.

Hope this will hello Your issue .

Answered By 0 points N/A #120935

Creative X-Fi Speakers not working on my Win 7

qa-featured

Hi good day,

This issue you need to install the driver version of your sound card, just visit this site: http://support.creative.com/kb/showarticle.aspx?sid=61105.

And find the model of the sound card. Then  download the driver of your sound card and it is compatible with Windows 7. Then after downloading install the driver of your sound card.

If it is not work follow this steps:

  1. If it is not work just right click on My Computer again > Manage > Click on “Services and Applications”> .click Services > find Windows Audio right click on it > Properties, and on the Windows Audio Properties ( Local Computer) click Start > then on Recovery select the computer’s response if this services fails. > select on it which you like. > click Apply and OK.
  2. On your task bar find the Speaker Volume icon > right click on it then Open Volume Control > if it is mute uncheck on it and close now your computers have a sound.

Thank you, hope its help

Regards;

Logictor

Login/Register to Answer

Related Questions