No network access even it is connected in the router

Asked By 7060 points N/A Posted on -
qa-featured

My laptop OS is windows 7,

It was connected to the internet but no network access,

What should i do?

SHARE
Best Answer by Sharath Reddy
Answered By 0 points N/A #84217

No network access even it is connected in the router

qa-featured

Hi, 

You can try disabling your firewall. If you have preinstalled McAfee on your laptop, try disabling it. 

Run > "msconfig" > Services.

Disable the McAfee network agent and the McAfee firewall core service.

If that does not work then you can do this methods:

Update the network driver

1.    Click on start button. 

2.    In the search box type devmgmt.msc and then press enter.

3.    Select the network card device and right click on it

4.    Now select properties.

5.    In the properties window, under Driver tab, click on Update Driver button.

6.    After the installing the updates restart the computer.

Reset the TCP/IP Stack

Follow the steps given in this link

Hope it helps!

Regards,

Romel

Best Answer
Best Answer
Answered By 566755 points N/A #84219

No network access even it is connected in the router

qa-featured

If you are sure that your computer is connected to the internet then there is probably a problem in the DNS configuration of your machine. To change the DNS servers set to your computer, click Start, Control Panel, Network and Internet Connections, then Network Connections. Right-click on the network connection you see and then select Properties.

Select Networking tab, select Internet Protocol (TCP/IP), and then click Properties. In General tab, select “Use the following DNS server addresses” and then enter these DNS server addresses in the respective fields:

  • 208.67.222.222
  • 208.67.220.220

These images describe the procedure above:

After that click OK and then restart your computer. After booting check if you now have an internet connection. If this doesn’t work then there is still something wrong with your configuration. Most of the time after signing up for an account with your Internet Service Provider, they don’t provide you your IP address.

This is actually fine since your computer can automatically fetch your IP address directly from your ISP so there is really no need for it. But there are times specifying your IP address in the setting fixes the network problem just like what happened to one of the computers in an internet shop where I was at before that can’t connect to the internet.

The owner entered the IP address instead of letting the computer automatically obtain the IP address. You may also try doing this on your computer. Repeat the steps above until you reach the General tab. Select “Use the following IP address” and then enter your own IP address in the specified field then click OK. See if this fixes it.

Login/Register to Answer

Related Questions