New version of ShoreTel server can’t connect

Asked By 0 points N/A Posted on -
qa-featured

 

The upgraded version of ShoreTel 11.0 server works fine with no issues at all. So I tried to install it to the new ShoreTel communicator to end-users and to our Citrix / Remote Desktop Servers.  When I log in without administrator/user permission in Citrix and run the new client, I get the following error message: "Encountered error while attempting to connect to server."

Why is this so? Is it not supported anymore? Please help. Thanks in advance.

 

SHARE
Best Answer by Carl Jack
Answered By 0 points N/A #94355

New version of ShoreTel server can’t connect

qa-featured

First thing to do is to login as the Administrator and check the Event Viewer. On the system events, you will see the DCOM error shown with the Event ID 10016 which simply means that the users are not allowed for the local Activation Permission on a specific CLSID as shown in the picture:

Copy the CLSID and then select Find on the regedit to view the file. The solution was at the lower portion of the event viewer in the status bar stating that the problem is due to the DCOM config for STClientLogin.

Now for the fix Follow the steps below:

1. Login as the Administrator and then go to Control Panel> Administrative Tools> Component Services. 

2. Expand and then select the DCOM Config and then search for the STClientLogin. 

3. Right-click to it and then click Properties. 

4. Select "Everyone" and click Add. And then check the Allow options on all the categories listed.

5. Click the OK button and close the window.

Thats it.You have now added the proper permissions for non-Administrator users to use the ShoreTel Communicator.

Best Answer
Best Answer
Answered By 0 points N/A #94357

New version of ShoreTel server can’t connect

qa-featured

Hello Maxie,

The following are the steps you will need to follow to fix the issue that you're getting:

  • First, you will need to login as an Administrator if you haven’t already.
  • And then you will go to Control Panel > Administrative Tools > Component Services.
  • Thereafter you will expand and then choose DCOM Config (choose No to any warnings that popup)
  • After that, locate STClientLogin, and then right-click, and choose Properties.
  • Next you will add the group Everyone and then give it Allow permissions to all the listed categories.
  • Once you have done the above, you will choose OK to close the appropriate windows and you are done.

Regards,

Carl

Login/Register to Answer

Related Questions