My PC takes long to shut down

Asked By 370 points N/A Posted on -
qa-featured

I am running XP Pro Service Pack 2 and the shutdown time it taking quite a long time, about 2 minutes or even more. This is quite annoying when you have to reboot. It’s wasting a lot of my precious time.

I recently updated drivers for my sound and video card. Blue screen problems started to appear immediately but i resolved the issue by uninstalling and reinstalling the drivers. When i try to shut down the computer, it takes a longer time than usual. Even when i have just started the PC and shut it down immediately, the shut down time is not less than 30 seconds.

Basically, i use 3 applications frequently. Adobe Photoshop, Illustrate and Adobe Go-Live. I have also noted the following:

  1. If carry out start up, check my emails straight away and then shut down immediately, the PC takes approximately 40 seconds to shut down completely.
  2. If i boot and then use Adobe Photoshop, Illustrate and Adobe Go-Live for about 4 hours, the shut down process takes approximately 5 minutes.
  3. During shut down process when i press the Restart button and then shut down, it takes about 1 minute to completely shut down.
  4. I had the same problem early this year and after a many trial and error diagnostics i managed to solve the problem. The funny thing is that now i don’t remember anything i did. I need this problem fixed. Please help.
SHARE
Best Answer by Peter Morales
Best Answer
Best Answer
Answered By 0 points N/A #106267

My PC takes long to shut down

qa-featured

Hello Gerald,

Having to startup our computers the fastest way possible has always been a common concern for most, if not all. They do affect productivity a lot, since the added minutes cause us to wait before finally being able to use it. But shutting down is as important, since we’re done for the day or need to take a much needed rest.

Here’s hoping that the fixes mentioned here does the trick for you. The amount of time it takes to shutdown depends largely on the number of programs running in the background to shutdown. So if you’ve done a lot of tasks, it means that there are several background processes still running apart from the main application you closed.

  • An effective way of dealing with this is to try and reduce the number of startups you have running as you boot your PC. The application “Autoruns” http://technet.microsoft.com/en-us/sysinternals/bb963902 may provide you with a comprehensive list of stuff that runs on one’s computer. Just extract the downloaded file from the link provided, run “autoruns.exe”, click on the “Logon” tab, uncheck entries that contain “Adobe” and close. Do the same for other apps that you don’t need running at startup. Doing so will increase your chances of having faster startup and shutdown times.
  • A heavily fragmented drive could cause slow shutdown speeds for all. Either use Microsoft’s built-in defragmenter or use “Defraggler” http://www.piriform.com/defraggler which gives you the option of just defragmenting the files that need to be defragmented, hence speeding up the whole process.
  • Speed up the waiting time to kill apps during shutdown by doing some minor registry tweaks. Here’s how:
  1. Go to “Start > Run”, type “regedit” without the quotes and “enter”.
  2. Navigate to “HKEY_CURRENT_USERControl PanelDesktop”.
  3. Set the value of the key “WaitToKillAppTimeout” to 1000.
  4. Locate the following key “HKEY_CURRENT_USERControl PanelDesktop”.
  5. Set the value of “AutoEndTasks” to “1”.
  • Create a “Shutdown” shortcut by right clicking on the desktop, “Create new shortcut”, typing “shutdown –s –t 0” without the quotes, and creating a name and icon for the shortcut. Just double click on the “Shutdown” shortcut you just created and time your shutdown.
  • The “Clear Pagefile at Shutdown” option may have been enabled, causing the disk to grind that long before finally shutting down. To disable it, just open “regedit” on your “Start > Run”, navigate to “HKLMSYSTEMCurrentControlSetControlSession ManagerMemory Management” and Set “ClearPageFileAtShutdown” value to 0.
  • Install “User Profile Hive Cleanup” http://www.microsoft.com/en-us/download/details.aspx?id=6676 to solve potential problems like slow shutdowns. It ensures that all user sessions are properly terminated before logoff or shutdown.
  • If you have an NVIDIA device on your system, the NVIDIA Driver Helper Service” could cause delays in shutdown. Upgrading to the latest NVIDIA drivers will solve the problem.
  • Disable the “Terminal Services” service to reduce shutdown time by about 10 seconds. To disable “Terminal Services”, just go to “Start > Run”, type “services.msc” without the quotes, double click on “Terminal Services” and disable. ”Terminal Services” is needed by Windows XP for running Remote Assistance, Fast User Switching, and Remote Desktop, so if you don’t do any of those, it can safely be stopped and disabled.
  • The “Event Log” can also slow down shutdown. To disable the “Event Log” service, launch the Services console as mentioned above, and disable Event Log by right-clicking on “Event Log”, clicking Properties and selecting “Disabled” under “Startup type”.
Answered By 0 points N/A #106268

My PC takes long to shut down

qa-featured

Hi Kim,

You can try this hope this will help.

  • HKEY_LOCAL_MACHINESYSTEMSCurrentControlSetControlSession ManagerMemory Management.
  • Then change the value of the ClearPageFile at Shutdown to a 0. A clue of 1 will overwrite the file which I would actually recommend for security.
  • Restart your PC.

Login/Register to Answer

Related Questions