My pc don’t support USB

Asked By 0 points N/A Posted on -
qa-featured

I'm unable to connect USB drive. When I'm trying to connect USB, it showing a error message. My pc's has 5 USB port, all USB port are active but it doesn't accept USB drive.

Please as soon as possible give solution so that I can use pen drive.

SHARE
Best Answer by tiffanydomes
Best Answer
Best Answer
Answered By 0 points N/A #112962

My pc don’t support USB

qa-featured

Hello Franchissco

Some times these type of problem occurs due to some problem with the USB drivers. Please follow the below steps to solve this problem.

  • Right click on "My Computer" and select properties.
  • Go to "Hardware" tab.
  • Click on "Device Manager"
  • Now click on the navigate to "Universal Serial Bus controllers". Open it clicking the + sign prefixed to it.
  • You might see all the USB port hubs and its controllers. Select each of them one by one and "Uninstall" them by right click. Do this for all that you see under "Universal Serial Bus controllers".
  • Once it is done close the device manager, click OK and restart your PC.
  • After your PC gets started again it automatically find USB ports as new hardware found. Be patient till a message is displayed which says "Your new hardware is installed now and ready to use"
  • You may now plug in your USB devices and check it.

Thanks!  

Answered By 563040 points N/A #112963

My pc don’t support USB

qa-featured
  • If USB-Universal Serial Bus is not detected then computer has no devices installed. This has a quick fix by downloading this file. See link below
  • http://support.microsoft.com/kb/314634#FixItForMe
  • There is also a manual fix for this if USB is not detected but your computer has 5 active USB ports.
  • You will need to modify the computer registry for USB drive. You must need to be carefully modify the registry page because one (1) mistake might occur problem, bigger problem.
  • Click start then Run and type regedit, press OK after
  • Locate this file and click it
  • HKEY_LOCAL_MACHINESystemCurrentControlSetServicesUSB
  • Go to Edit men and on New, then click DWORD
  • Type disableSelectiveSuspend and you need to press Enter
  • Going back on Edit Menu, click on Modify
  • Type 1 and press Ok button

This should let you use your USB and activate the use of pen drive.

Login/Register to Answer

Related Questions