My Lenovo x100 laptop is way too slow

Asked By 0 points N/A Posted on -
qa-featured

I have a question regarding my laptop. I have an 11.6" HD Lenovo x100 that has an AMD Athlon Single-Core MV-40 Processor 1.66 GHz, 2 GB DDR2 RAM, 250 GB SATA HDD, ATI 3200 Graphics and an upgraded Windows 8 OS. Ever since upgrading to Windows 8, my laptop has been too slow. It even takes a longer than the usual time booting up. What could be the problem of my Lenovo x100?

SHARE
Best Answer by Fran Kristopher
Best Answer
Best Answer
Answered By 240 points N/A #170270

My Lenovo x100 laptop is way too slow

qa-featured

Wassup Hink, I think I will be able to help you find a solution to this problem since it has been solved before. You need to ensure that your laptop has all the specifications required for Windows 8; ensure it has a Processor of at least 1 GHz, RAM of 1 GB or more, Hard disk space of 20 GB or above, screen resolution of about 1366*768.

Your computer seems to have passed all these qualities leaving it with perhaps only one problem, the screen resolution or the virtual memory. Your computer's virtual memory may probably be the most likely cause of this problem. I would recommend you to download the Ccleaner to clean any unused memory in your computer.  You will be able to download it from the website; http://www.piriform.com/ccleaner

Piriform CCleaner

Once you download the software, you will then scan your computer free any unused memory. You also need to increase the virtual memory by right-clicking on the 'My computer' tab -> Clicking on 'Settings' -> 'Advanced Tab' -> 'Change' tab under 'Performance'. You can then uninstall and reinstall the Windows 8.

Vitual Memory Settings

It should be able to work well now.

I hope this solves your query.

Thanks.

Answered By 0 points N/A #170271

My Lenovo x100 laptop is way too slow

qa-featured

Dear Hink Larbert,

The problem of slowness while booting up is very common in the Windows operating system, but this can be resolved very easily by reducing the startup applications during boot up.

This can be done with the follow simple steps:

1- Open the Run command in start menu and type “msconfig”.
2- Go to the startup tab and uncheck undesired programs to stop them from running during the boot up process.
3- Simply close the window and restart your PC.

After that the startup programs will have been reduced which should shorten the time booting up.

Hope to be helpful.

Best regards,

Don Muench

Login/Register to Answer

Related Questions