Mozilla Firefox 5.0 Encryption Problem

Asked By 470 points N/A Posted on -
qa-featured

I'm having this kind of problem, that if I open my working website there is a warning that the website uses a code that is enabled. So I went to options > advanced > encryption and I saw there that both ssl and tl are enabled. I can even open the website in my latest IE version and it works fine, and can open the site in an older version of Mozilla. What makes it so difference?

And my second issue is whenever I opened MF, I got a message "A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete". It is very irritating when I open Mozilla Firefox. 

Somebody would help me on this please?

SHARE
Best Answer by Harry
Best Answer
Best Answer
Answered By 200 points N/A #102122

Mozilla Firefox 5.0 Encryption Problem

qa-featured

This error message says that Firefox cannot securely connect to the web site which you are going to run, because it uses a security protocol which is not enabled. So Firefox cannot do more about that.

Newer version of Firefox supports the SSL version 3.0. Older version supports a lower version of SSL that’s why you can run it on an older version of Firefox. So Not enabling the encryption protocol is seems to be unsafe.

You can however enable it; I mean you can enable a lower version of SSL. But not from the Tools.

Type about: config in address bar and hit enter.

And then you'll get a notification of saying 'This might void your warranty!' And some other stuff.

Just press the button 'I'll be careful, I promise'.

Find security.enable_ssl2 and change the value to true.

And also set security.ssl2.des_ede3_192 into value true.

And security.ssl3.rsa_rc4_40_md5 preference to true.

When talk about the other problem of yours, which error is telling you that Firefox thinks that there is a script running out of control, some internal script is ran out of time. This would might happen when a script has a lot of things to do, or the script has a bug. And it causes the Firefox to hang if nothing is done. This script may be something on a web page that you are accessing, or an extension that you are going to install in Firefox, or even Firefox itself.

If you tried to send a message using a very large mailing list, sending personalized messages using the Mail Tweak extension, fetching new mail using the webmail extension which can be lengthy operations can also cause this error.

If you suspected that this script has a bug, Press the ‘Stop Script’ button. And also if you do not know what the script that is running is, and then just hit the "Stop script" button as above to stop the script.

If you experience that pressing continue button only brings up the same message again, letting it continue will not help you any longer. It will only hang Firefox without doing anything.

If it works normally after pressing continue, it seems that the script need some extra time to process the script to complete. Then this appearing of message will be a trouble maker to you. To avoid that you can give some extra time to Firefox for process a script.

Like the above type about: config and get the screen by following the above described steps.

Search for dom.max_script_run_time preference and double click on it. Then a prompt box will be appearing.

Type 20 in the Enter integer value. This means you are going to increase the time limit 20 seconds.

If you specify it as 0, it allows script to run for a very long time (I mean forever, infinite).

But remember if you define a long time, then any script that has a bug or error, will run for that time period before you can stop it. So it's not a recommended idea to specify it as 0.

So from now on, you will not be receiving any unnecessary dialog box warnings of unresponsive scripts.

Answered By 0 points N/A #102123

Mozilla Firefox 5.0 Encryption Problem

qa-featured

You can stop that prompt that tells you all the time to stop running the script or continue using the simple procedure below:

  1. You will need to open Firefox and then go to the location bar, or otherwise known as the address bar and type there about: config and then press Enter.

    • The about: config page that has the message "This might void your warranty!" warning will appear, and then you will be supposed to click "I'll be careful, I promise!, to continue to the about: config page".
  2. When still in the about: config page, you will need to search for the preference dom.max_script_run_time, and then you will double-click on it.
  3. You will have to type 20 in the Enter integer value prompt.
  4. And then press OK.

That way, you will have disabled the scripts and they will not run longer times, and thus you will no longer receive the prompt.

-Clair Charles

Login/Register to Answer

Related Questions