Microsoft Visio Studio – Looking for solution

Asked By 30 points N/A Posted on -
qa-featured

Hi

I have quite a few packages and they are exporting from SQL 05 to excel files. Also they run effectively for a few weeks.

But at this moment when I attempt to chart in the excel columns I find an error message.

Excel connection manager, Microsoft jet database engine unspecified error. Hresult 0x80004005.

However I have got a few answers on the internet saying that I need to repair excel on the machine, but nothing happens after that.

I don't feel I am utilizing a Jet Driver; also my source query is utilizing a source connection OLEDB with driver Native OLE DB/SQL Native Client.

Microsoft Visual Studio

 
Error at 3 AUS Resources [Connection manager "Supplier Excel"]: SSIS Error Code DTS_E_0LEDBERROR.
An OLE DB error has occurred. Error code: 0x80004005.
An OLE DB record is available. Source: ""Microsoft Access Database Engine“ Hresult: 0x80004005
Description: "Unspecified error".
 
Error at Data Flow Task [Supplier Excel [4092]]: SSIS Error Code
DTS_E_CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER. The AcquireConnection method
call to the connection manager "Supllier Excel" failed with error code 0xC0202009. There may be error
messages posted before this with more information on why the AcquireCornnection method call failed.
 
Additional information:
-> Exception from HRESULT: 0xC020801C (Microsoft.SqlServer.DTSPipelineWrap)
 
                                                                                            OK

 

I need to solve this. Please give a solution.

Thanks a lot.

SHARE
Answered By 0 points N/A #150889

Microsoft Visio Studio – Looking for solution

qa-featured

Hello Andrew,

Try the following workarounds to solve the issue you are having:

Solution 1:

Ensure that the path to the excel workbook is correct.

You can also try creating the workbook from within the SSIS so that it can be able to use the office web tools.

Solution 2:

  • Locate the solution and right click on it, and then go to properties.
  • Next you will have to click the left hand side Debugging option.
  • Navigate to the right hand side  and click on the Debugging options,
  • And then  click on Run64bitruntime.
  • Change its option to false

Hope these helps.

Regards,

Carl

 

Login/Register to Answer

Related Questions