Microsoft Register Server not working

Asked By 200 points N/A Posted on -
qa-featured

Thanks for your help. I started my HP laptop with Windows 7 64 bit installed on it but during the middle of the booting process, there was an error message appeared on the screen saying.

“Microsoft (C) Register Server has stopped working. ” I visited the customer service website for Windows Vista and they suggested some points on how I could fix the problem. And so, I followed the directions that the customer support team had instructed to me. I turned on the Data Execution Program (DEP) for all programs and added the Regsvr32 on it. Afterwards, I restarted my laptop but unexpectedly, the same error had occurred.

I hope you can help me. Thank you.

SHARE
Best Answer by mackycarandang
Best Answer
Best Answer
Answered By 0 points N/A #111674

Microsoft Register Server not working

qa-featured

Hi,

I have read the issue that you have and you may want to try this solution that I have. The problem that you have usually happens due to the data execution prevention, so what we need to first is adding it in the exception for data execution prevention. Here are the steps on how to do the solution:

  1. Click Start button
  2. Click Control Panel on the right side of the menu
  3. Click on System
  4. Click on the advanced tab
  5. Look for Performance and then click settings
  6. Click on Data Execution Prevention
  7. Turn on data execution prevention for all programs and services except for those selected radio buttons
  8. Click the Add button
  9. Look on the file: C:/Windows/System32
  10. Click on regsvr32.exe file

You will see a message showing it could make your computer become unprotected and vulnerable to attacks, click OK

Click OK on the first box and then click OK again to exit the other box.

If you will have the same issue, we need to perform a clean boot. Here are the steps:

Log on as the administrator user of the computer.

  1. Click Start button.
  2. Look for start search or search programs and file bar and type in msconfig.exe.
  3. Hit Enter..
  4. The System Configuration utility will open up.
  5. On the General tab, click option Selective startup.
  6. Clear/ uncheck the option Load startup items check box.
  7. On the Services tab, Put a check on Hide all Microsoft services check box.
  8. Click Disable all.
  9. Click OK, and then click Restart.

The next steps are as follows:

  1. Log on as the administrator user of the computer.
  2. Click Start button.
  3. Look for start search or search programs and file bar and type in msconfig.exe.
  4. Hit Enter.
  5. The System Configuration utility will open up.
  6. Click the Services tab, and then Put a check on Hide all Microsoft services check box.
  7. Put a check on select half of the check boxes in the Service list.
  8. Click OK, and then click Restart.

If the problem occurs again do the same steps from the clean boot and uncheck half of the check boxes that you originally selected in the Service list.

If the problem was resolved, repeat steps from the clean boot and put a check on the half of the remaining check boxes that are cleared in the Service list. Repeat these steps until you have selected all the check boxes.

 

Login/Register to Answer

Related Questions